summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-04 13:38:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-04 17:07:35 +0200
commitea5afcdfa2ed14e119ecf41f5b2000e3b978bf6d (patch)
tree1e3c5daf3cf4c79c44329ca4e8b4eb8df84b98c9 /app-emacs
parentapp-emacs/org-modern: bump to 1.3 (diff)
downloadgentoo-ea5afcdfa2ed14e119ecf41f5b2000e3b978bf6d.tar.gz
gentoo-ea5afcdfa2ed14e119ecf41f5b2000e3b978bf6d.tar.bz2
gentoo-ea5afcdfa2ed14e119ecf41f5b2000e3b978bf6d.zip
app-emacs/yasnippet-snippets: bump to 1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/yasnippet-snippets/Manifest1
-rw-r--r--app-emacs/yasnippet-snippets/yasnippet-snippets-1.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-emacs/yasnippet-snippets/Manifest b/app-emacs/yasnippet-snippets/Manifest
index 5faecb3c5545..e5a47101d528 100644
--- a/app-emacs/yasnippet-snippets/Manifest
+++ b/app-emacs/yasnippet-snippets/Manifest
@@ -1 +1,2 @@
DIST yasnippet-snippets-1.0.tar.gz 178027 BLAKE2B 0b44c94c3ad3f2a1208aefba110945aeae74e7278c93078c59677985efc89767b670c99b4b8303b56ea0b748375762ada1e45653e02922b248273af5818514d4 SHA512 2df010f24e51d0156bcb3d488cd6a63a47d2d92e4c5f3cd081e377dc91426d630bde41db6f79d1b5ac1e932e4d0ab11f9be945e94fb35d50b1789adab19bd15b
+DIST yasnippet-snippets-1.1.tar.gz 179315 BLAKE2B 23413fa35612a8583d3919ce1597e7519d0f4f28a537d8fc18f09d3bd1213c161f3f5987bcd727b73bddd3a94098059e8ba284b4491b3fec528465c840518565 SHA512 4f2fa91e9749e4035fcf643a3ef319bbadabe9b07630db4615da9ae2df8784b3c1155ebae83764e7ed7b0db957a80c97451de388b129438955d6aacf25753bc2
diff --git a/app-emacs/yasnippet-snippets/yasnippet-snippets-1.1.ebuild b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.1.ebuild
new file mode 100644
index 000000000000..13490ccc3e98
--- /dev/null
+++ b/app-emacs/yasnippet-snippets/yasnippet-snippets-1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp edo
+
+DESCRIPTION="A collection of yasnippet snippets for many languages"
+HOMEPAGE="https://github.com/AndreaCrotti/yasnippet-snippets"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/AndreaCrotti/${PN}.git"
+else
+ SRC_URI="https://github.com/AndreaCrotti/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/yasnippet
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-dir.patch" )
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i "${PN}.el" || die
+}
+
+src_compile() {
+ elisp_src_compile
+
+ edo ${EMACS} ${EMACSFLAGS} \
+ --eval "(require 'yasnippet)" \
+ --eval "(yas-compile-directory \"${S}/snippets\")"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r snippets
+}