summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-11 17:20:14 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-11 17:34:30 +0200
commit162cd1d52ce9f9eae72ab2d20eb5a3bd67ac2746 (patch)
treed3054372fb173fa03ace77f49305cc796e17ed11 /app-emacs
parentapp-emacs/plz: new package; add 0.5.4 (diff)
downloadgentoo-162cd1d52ce9f9eae72ab2d20eb5a3bd67ac2746.tar.gz
gentoo-162cd1d52ce9f9eae72ab2d20eb5a3bd67ac2746.tar.bz2
gentoo-162cd1d52ce9f9eae72ab2d20eb5a3bd67ac2746.zip
app-emacs/burly: new package; add 0.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/burly/Manifest1
-rw-r--r--app-emacs/burly/burly-0.2.ebuild39
-rw-r--r--app-emacs/burly/files/50burly-gentoo.el2
-rw-r--r--app-emacs/burly/metadata.xml20
4 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/burly/Manifest b/app-emacs/burly/Manifest
new file mode 100644
index 000000000000..eed6ef6c8fb6
--- /dev/null
+++ b/app-emacs/burly/Manifest
@@ -0,0 +1 @@
+DIST burly-0.2.tar.gz 231242 BLAKE2B e50999727d654485c8265a163849f26867721f914c59b501ca8a4a42a1c12589adcd5d85b3d9ca5a383cf235962f7ca8dd8668abed1b3453b256100043875ebd SHA512 75dc26d1fae53a3ce238318e184396b2d67ce08f500c185d9fd526d6fb50c2ea3ba5a5d60789cd9b111f37336f66b1e014a19cda8bb387d6add1484cf6dd8548
diff --git a/app-emacs/burly/burly-0.2.ebuild b/app-emacs/burly/burly-0.2.ebuild
new file mode 100644
index 000000000000..787e5f49350a
--- /dev/null
+++ b/app-emacs/burly/burly-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Save and restore frames and windows with their buffers in Emacs"
+HOMEPAGE="https://github.com/alphapapa/burly.el"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/${PN}.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.info
+}
diff --git a/app-emacs/burly/files/50burly-gentoo.el b/app-emacs/burly/files/50burly-gentoo.el
new file mode 100644
index 000000000000..e19cf1e132b9
--- /dev/null
+++ b/app-emacs/burly/files/50burly-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "burly-autoloads" nil t)
diff --git a/app-emacs/burly/metadata.xml b/app-emacs/burly/metadata.xml
new file mode 100644
index 000000000000..1d53db179306
--- /dev/null
+++ b/app-emacs/burly/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This package provides tools to save and restore frame and window
+ configurations in Emacs, including buffers that may not be live anymore. In
+ this way, it’s like a lightweight "workspace" manager, allowing you to
+ easily restore one or more frames, including their windows, the windows'
+ layout, and their buffers.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/alphapapa/burly.el/issues/</bugs-to>
+ <remote-id type="github">alphapapa/burly.el</remote-id>
+ </upstream>
+</pkgmetadata>