summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-13 18:11:45 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-13 22:57:02 +0200
commitb24cfdfbea7ccd91289c4096e909e43c161c8e5f (patch)
tree2f96d6d874ba737cbcb61fd8d81776978035001b /app-emacs/php-mode/php-mode-1.26.1.ebuild
parentapp-emacs/orderless: bump to 1.2 (diff)
downloadgentoo-b24cfdfbea7ccd91289c4096e909e43c161c8e5f.tar.gz
gentoo-b24cfdfbea7ccd91289c4096e909e43c161c8e5f.tar.bz2
gentoo-b24cfdfbea7ccd91289c4096e909e43c161c8e5f.zip
app-emacs/php-mode: bump to 1.26.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/php-mode/php-mode-1.26.1.ebuild')
-rw-r--r--app-emacs/php-mode/php-mode-1.26.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/php-mode/php-mode-1.26.1.ebuild b/app-emacs/php-mode/php-mode-1.26.1.ebuild
new file mode 100644
index 000000000000..c61824e10dae
--- /dev/null
+++ b/app-emacs/php-mode/php-mode-1.26.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for editing PHP code"
+HOMEPAGE="https://github.com/emacs-php/php-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-php/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-php/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../AUTHORS.md ../CHANGELOG.md ../CONTRIBUTING.md ../README{,.ja}.md ../docs )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert "${S}" -L ../tests -l ../tests/php-mode-test.el
+
+src_test() {
+ touch ../tests/project/1/.git || die
+
+ elisp_src_test
+}