summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-17 14:41:08 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-17 15:39:32 +0200
commit81c0c28c3d234ca3918c1fbed76c3cacabc59316 (patch)
tree25d6687ed83a2441d14f3cbfb20c129b177e5d0c /app-emacs/osm
parentdev-lang/luau: drop old 0.597 (diff)
downloadgentoo-81c0c28c3d234ca3918c1fbed76c3cacabc59316.tar.gz
gentoo-81c0c28c3d234ca3918c1fbed76c3cacabc59316.tar.bz2
gentoo-81c0c28c3d234ca3918c1fbed76c3cacabc59316.zip
app-emacs/osm: bump to 0.14
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/osm')
-rw-r--r--app-emacs/osm/Manifest1
-rw-r--r--app-emacs/osm/osm-0.14.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/osm/Manifest b/app-emacs/osm/Manifest
index d96998ad64d9..933440d4b753 100644
--- a/app-emacs/osm/Manifest
+++ b/app-emacs/osm/Manifest
@@ -1 +1,2 @@
DIST osm-0.13.tar.gz 32400 BLAKE2B 0b97d1adb67510f393dc13b8f314e8b8cc089d1b5d4e440331a2c8ddf42799c5e04b6448eb35d3acd55c8fc363f82415d8b8cdf83e06fa3ccccceaa07ffd68e4 SHA512 4313ccb42c6c7a7fc582d5f2a476ff09890306c82bf0554654443906e593509692450d0db4b6ef4fde906aa750d925bd3156e74d8fcf6f780eb37a3761aa20e6
+DIST osm-0.14.tar.gz 32982 BLAKE2B 0c6672aa259c840d0da628bcc8dbac86e9801a18cec70fff997c34af54a7f1d0f4c1a746069347cca1af8a3282de59e3604c5c7faf52a646bbf718f4544425e6 SHA512 e8f294d449f1863653d7a2b6105bc21917b616e734c7014bd8b15299dbf79d764f3bfbe92512088934e069d4be6397f4b8687f1be105053ec4b2f32458ea02ec
diff --git a/app-emacs/osm/osm-0.14.ebuild b/app-emacs/osm/osm-0.14.ebuild
new file mode 100644
index 000000000000..e18c2dbd3553
--- /dev/null
+++ b/app-emacs/osm/osm-0.14.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="OpenStreetMap tile-based viewer for GNU Emacs"
+HOMEPAGE="https://github.com/minad/osm/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}:*[jpeg,json,libxml2,png,svg]
+ >=app-emacs/compat-29.1.4.0
+"
+RDEPEND="
+ ${BDEPEND}
+ net-misc/curl[ssl]
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}