summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2024-01-14 21:25:30 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-14 22:39:12 +0200
commit008bbbe3df4c92f0d9483c0300faadbba19d36f9 (patch)
tree3eba72eb89aea25c0101cb5a2602a434f1631ba7 /app-editors
parentapp-editors/vscodium: add 'wayland' USE flag (diff)
downloadgentoo-008bbbe3df4c92f0d9483c0300faadbba19d36f9.tar.gz
gentoo-008bbbe3df4c92f0d9483c0300faadbba19d36f9.tar.bz2
gentoo-008bbbe3df4c92f0d9483c0300faadbba19d36f9.zip
app-editors/vscodium: add EGL useflag for smooth rendering
Rendering on vscode is limited to 60fps by default. This useflag makes vscode match the monitor's refresh rate, at least on x11/xwayland. In my testing, it did not change anything on wayland with wayland mode. See https://github.com/microsoft/vscode/issues/65142 Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Closes: https://github.com/gentoo/gentoo/pull/34808 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/metadata.xml1
-rw-r--r--app-editors/vscodium/vscodium-1.84.2.23319-r2.ebuild (renamed from app-editors/vscodium/vscodium-1.84.2.23319-r1.ebuild)5
-rw-r--r--app-editors/vscodium/vscodium-1.85.1.23348-r2.ebuild (renamed from app-editors/vscodium/vscodium-1.85.1.23348-r1.ebuild)5
3 files changed, 9 insertions, 2 deletions
diff --git a/app-editors/vscodium/metadata.xml b/app-editors/vscodium/metadata.xml
index bf602df2c98c..8d4e8c9c718e 100644
--- a/app-editors/vscodium/metadata.xml
+++ b/app-editors/vscodium/metadata.xml
@@ -14,6 +14,7 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
+ <flag name="egl">Use EGL platform, enables smooth rending in high refresh rate monitors on X11/Xwayland</flag>
<flag name="wayland">Run in wayland mode under wayland sessions, xwayland otherwise. This flag doesn't affect x11 sessions.</flag>
</use>
<longdescription>
diff --git a/app-editors/vscodium/vscodium-1.84.2.23319-r1.ebuild b/app-editors/vscodium/vscodium-1.84.2.23319-r2.ebuild
index 851a49f88afb..2d614534f45e 100644
--- a/app-editors/vscodium/vscodium-1.84.2.23319-r1.ebuild
+++ b/app-editors/vscodium/vscodium-1.84.2.23319-r2.ebuild
@@ -42,7 +42,7 @@ LICENSE="
"
SLOT="0"
KEYWORDS="-* amd64 ~arm ~arm64"
-IUSE="kerberos wayland"
+IUSE="egl kerberos wayland"
RESTRICT="strip bindist"
RDEPEND="
@@ -104,6 +104,9 @@ src_install() {
if use wayland; then
EXEC_EXTRA_FLAGS+=( "--ozone-platform-hint=auto" )
fi
+ if use egl; then
+ EXEC_EXTRA_FLAGS+=( "--use-gl=egl" )
+ fi
sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
"${FILESDIR}/vscodium-url-handler.desktop" \
diff --git a/app-editors/vscodium/vscodium-1.85.1.23348-r1.ebuild b/app-editors/vscodium/vscodium-1.85.1.23348-r2.ebuild
index ceadf3473c69..dff9e2aafd31 100644
--- a/app-editors/vscodium/vscodium-1.85.1.23348-r1.ebuild
+++ b/app-editors/vscodium/vscodium-1.85.1.23348-r2.ebuild
@@ -42,7 +42,7 @@ LICENSE="
"
SLOT="0"
KEYWORDS="-* ~amd64 ~arm ~arm64"
-IUSE="kerberos wayland"
+IUSE="egl kerberos wayland"
RESTRICT="strip bindist"
RDEPEND="
@@ -104,6 +104,9 @@ src_install() {
if use wayland; then
EXEC_EXTRA_FLAGS+=( "--ozone-platform-hint=auto" )
fi
+ if use egl; then
+ EXEC_EXTRA_FLAGS+=( "--use-gl=egl" )
+ fi
sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
"${FILESDIR}/vscodium-url-handler.desktop" \