summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-09 22:19:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-09 22:19:42 +0200
commitb2180d9318378d12c5d55cb74e50162c99512359 (patch)
treeb3435895b20c08e82fc71e84ad39fe5766bcaaf9 /app-editors/mousepad
parentdev-python/sphinx: Remove old (diff)
downloadgentoo-b2180d9318378d12c5d55cb74e50162c99512359.tar.gz
gentoo-b2180d9318378d12c5d55cb74e50162c99512359.tar.bz2
gentoo-b2180d9318378d12c5d55cb74e50162c99512359.zip
app-editors/mousepad: Bump to 0.5.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-editors/mousepad')
-rw-r--r--app-editors/mousepad/Manifest1
-rw-r--r--app-editors/mousepad/mousepad-0.5.10.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 622fc67807c9..a7981fd9d57a 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1 +1,2 @@
+DIST mousepad-0.5.10.tar.bz2 959696 BLAKE2B bd21145f23f1e92d67489a3ffcdca0afd977aa639706dece5aefd2f5417d2b2122accc1a5c727ec13a4c2f311ec479612953006d78b5509e836f360566d0d320 SHA512 144e72abce8e5fb66a345fb59efe48f136dd9cf9cdcd72496dcee05b08781bdbba036f4ab5af04dbccd38dc52a8e8dd67b5b7434867881a1114de692a012b076
DIST mousepad-0.5.9.tar.bz2 953685 BLAKE2B f8db50048964c789600ce6d310f6b6a893d7d4406d55f0666b7e78bf3e54446d3ec56eb70a059da6fac367d7c3f3fc5861fb29dadf28aa9b0d5e2f62056f3dfb SHA512 915fa1c89d66f793c4dba7826b4934e286e940dbdd9c933bddeeaf76be79d2140cd0feb1dea2946989879ec354d57af36fd61517309ebd4915f18be4b9cf621f
diff --git a/app-editors/mousepad/mousepad-0.5.10.ebuild b/app-editors/mousepad/mousepad-0.5.10.ebuild
new file mode 100644
index 000000000000..dc34dc267e55
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.5.10.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.52
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}