summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-02-15 19:36:47 +0100
committerUlrich Müller <ulm@gentoo.org>2022-02-15 19:48:58 +0100
commita4ff1a1c9a66a3a659358b88b3546f04783285c6 (patch)
treeb71a43fff31531fb1ee1604f40af6173738784ab /app-editors/jove
parentwww-client/chromium: fix building with gtk4 (diff)
downloadgentoo-a4ff1a1c9a66a3a659358b88b3546f04783285c6.tar.gz
gentoo-a4ff1a1c9a66a3a659358b88b3546f04783285c6.tar.bz2
gentoo-a4ff1a1c9a66a3a659358b88b3546f04783285c6.zip
app-editors/jove: Version bump to 4.17.3.7
Upstream labels this as a pre-release, so it is _not_ a candidate for stabilisation. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/jove')
-rw-r--r--app-editors/jove/Manifest1
-rw-r--r--app-editors/jove/jove-4.17.3.7.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-editors/jove/Manifest b/app-editors/jove/Manifest
index f8f0ce69df7f..5528d9543721 100644
--- a/app-editors/jove/Manifest
+++ b/app-editors/jove/Manifest
@@ -1 +1,2 @@
+DIST jove-4.17.3.7.tar.gz 490070 BLAKE2B bfe95cc8f78993438839b93ebf37567940449e3914dd1963728ee82dc601c371318a34ea0d5d13d9d4dccaf9c4750874c5e0d3af22dcb2421595dca2da7cafdf SHA512 90bd597bb4be3a4589f77ee331cee4fa2784264221fe6247c2535ae34c5689c08f55c2b2919bff34af5631b73b12883dab54df9770b4157ae801079a23222d9a
DIST jove4.16.0.73.tgz 465214 BLAKE2B cc1eeca2cdbd7ca98a5deaf27c37bfcdc529f2b388361e0cd5fd6278b72740a06283abd1f60212e6dc0d1e540e4dc4d99edb99b781645b13e1675644db0f38eb SHA512 2198504f9a23590710acba7f27661fa5649fdbed559a4c6bde9d2c1d673c22ce7d99a690be45a4602d37cf6e70399230c4ae3a251d8451af0c5252bdca61b09d
diff --git a/app-editors/jove/jove-4.17.3.7.ebuild b/app-editors/jove/jove-4.17.3.7.ebuild
new file mode 100644
index 000000000000..3c41a1a75685
--- /dev/null
+++ b/app-editors/jove/jove-4.17.3.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Jonathan's Own Version of Emacs, a light emacs-like editor without LISP bindings"
+HOMEPAGE="https://github.com/jonmacs/jove"
+SRC_URI="https://github.com/jonmacs/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="JOVE"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ tc-export CC
+
+ emake \
+ JOVEHOME="${EPREFIX}/usr" \
+ JMANDIR="${EPREFIX}/usr/share/man/man1" \
+ OPTFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ SYSDEFS="-DLinux" \
+ TERMCAPLIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+
+ if use doc; then
+ # Full manual (*not* man page)
+ emake doc/jove.man
+ fi
+}
+
+src_install() {
+ emake \
+ JOVEHOME="${EPREFIX}/usr" \
+ JMANDIR="${EPREFIX}/usr/share/man/man1" \
+ DESTDIR="${D}" \
+ install
+ keepdir /var/lib/jove/preserve
+
+ dodoc README
+ if use doc; then
+ dodoc doc/jove.man
+ fi
+}