summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 14:28:46 +0100
committerSam James <sam@gentoo.org>2022-10-04 14:28:46 +0100
commita9bde9f8512a293256b99a586a2f1964ed3d6162 (patch)
treed6efd747b7c951709650ae2a35e5f42b5a836b09 /app-editors/gvim/gvim-9999.ebuild
parentapp-editors/vim: sync live (diff)
downloadgentoo-a9bde9f8512a293256b99a586a2f1964ed3d6162.tar.gz
gentoo-a9bde9f8512a293256b99a586a2f1964ed3d6162.tar.bz2
gentoo-a9bde9f8512a293256b99a586a2f1964ed3d6162.zip
app-editors/gvim: sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 66490dcc956e..41d899a1c67d 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -11,7 +11,7 @@ PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
USE_RUBY="ruby27 ruby30 ruby31"
-inherit vim-doc flag-o-matic xdg-utils bash-completion-r1 prefix lua-single python-single-r1 toolchain-funcs ruby-single
+inherit bash-completion-r1 flag-o-matic lua-single prefix python-single-r1 ruby-single toolchain-funcs vim-doc xdg-utils
if [[ ${PV} == 9999* ]]; then
inherit git-r3
@@ -29,7 +29,7 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
LICENSE="vim"
SLOT="0"
-IUSE="acl aqua crypt cscope debug lua motif netbeans nls perl python racket ruby selinux session sound tcl"
+IUSE="acl aqua crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -76,6 +76,7 @@ BDEPEND="
lua? ( ${LUA_DEPS} )
nls? ( sys-devel/gettext )
"
+PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
# various failures (bugs #630042 and #682320)
RESTRICT="test"