summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-07 20:47:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-07 20:47:17 +0200
commitd930df34a96e353a9bef4de7249e7a5955234274 (patch)
tree0adde210dc5032ec5e0950412673179a3fe144d8 /app-doc
parentdev-python/python-tests: Bump to 3.13.0 (diff)
downloadgentoo-d930df34a96e353a9bef4de7249e7a5955234274.tar.gz
gentoo-d930df34a96e353a9bef4de7249e7a5955234274.tar.bz2
gentoo-d930df34a96e353a9bef4de7249e7a5955234274.zip
app-doc/python-docs: Bump to 3.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/python-docs/Manifest1
-rw-r--r--app-doc/python-docs/python-docs-3.13.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-doc/python-docs/Manifest b/app-doc/python-docs/Manifest
index 7b27edab1bd7..c607476aa9bb 100644
--- a/app-doc/python-docs/Manifest
+++ b/app-doc/python-docs/Manifest
@@ -3,5 +3,6 @@ DIST python-3.10.15-docs-html.tar.bz2 7452520 BLAKE2B e9003e2a839bc934d3ba5903e1
DIST python-3.11.10-docs-html.tar.bz2 7988162 BLAKE2B bc0d47ca235c8c14c4f62b554578068bf3e8460211e358cec586511be35b0aa2011075ace0602385dca2b4c2667d6bd3cb8ce4e6e6be1ed52d84b877cf3a7f6a SHA512 a14e18d3641d4379144ead7341536c781a94e9f15c9b53b2647a7c7c4cd15211963564fb2519e756b79db9234f555ede2442a678d6b4f27de6f7fb0b2993c266
DIST python-3.12.6-docs-html.tar.bz2 8360479 BLAKE2B 09294f5ba1ca8f53c0261e0db626aeb62ac3d66115b87feb212987ca181a2d6324a24eda97b374e6ea56e93623e487da23c50613335af4166ecba845837ae582 SHA512 5f5d37ea047810c0ae3a99585008ee02a3d4dd1b3eb573dc96eaf590c542267034fafdefd1aeb2b3e59a5b5019e4dc2562ed27d1699013c7a0609b557e5ce27c
DIST python-3.12.7-docs-html.tar.bz2 8390435 BLAKE2B 4541c8e553b8d8aef79b266c874d9023de2cc2eba764a67cf2c2f3bc83cc7b8e614473d2667c5b3ba394cad353385af9a02621bec4fd0a58b37c7c2af719002b SHA512 812586ca009d16ffa5be957b56489d9a3aca90fed225f5ef202863d45c9e90a5f0997068c9fd9b284a356467574e0f31f6154118f4b40300e739b3341e9f73e4
+DIST python-3.13.0-docs-html.tar.bz2 10238095 BLAKE2B e413eb5b2935734c2ea3aacc03be142e904c7e693acd3dfe8559d42694cbb67f0cd724927d19b3361f401f88ed17aec529ec91807d73558169cd160d9ebbd730 SHA512 446c53c2a091ac369c4f498d5fa2de99719478a12827751e291e0372b9f148c3757a4b76599ceec95180a926d4fc2030a412392542552638e602b4577f8b6902
DIST python-3.8.20-docs-html.tar.bz2 6727651 BLAKE2B ec11857b5bdfb4646a2762353db877a558cfc543563a7a9b0db100f675511c31450d16c30a986d39226a9b16be3ffd132863e396ef05165047ab73bf037bf2a6 SHA512 0a77f0240d6d495a5099d4a95e151f38517730815e6f3d9b82964cf60be95b8bdc960916d317e19bb8e14a9604217cd1fa85703996aec972004a6a93d4ffa6d0
DIST python-3.9.20-docs-html.tar.bz2 6988218 BLAKE2B 0e463d8fa0643a9c01ba52d35c8880b00f5d4b83d778947937ac86e2db4f5af312d6d2b580ceb498db76c0ca61231befaf0fc6d1a17d8b1b84981ddea16bcebb SHA512 524ebdc8b082ba50691fb8eadf6bf17374a1d9d6e61a6b49efecf597bbd2c7b50bca908fb94c5ca9350c06895330d88086d0d1ee9ccb7306362b1cd37282a53d
diff --git a/app-doc/python-docs/python-docs-3.13.0.ebuild b/app-doc/python-docs/python-docs-3.13.0.ebuild
new file mode 100644
index 000000000000..af0422ec51e4
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.13.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P=python-${PV}-docs-html
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}