summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-01-25 19:23:19 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-01-25 19:24:44 +0300
commit66b42d5b9d310dda0d92da76ced50fe1d0cc22a1 (patch)
treeaed6f2947c6272351fe68ef08743c4ccda11b5df /app-crypt
parentnet-fs/samba: Drop 4.13.3 (r0) (diff)
downloadgentoo-66b42d5b9d310dda0d92da76ced50fe1d0cc22a1.tar.gz
gentoo-66b42d5b9d310dda0d92da76ced50fe1d0cc22a1.tar.bz2
gentoo-66b42d5b9d310dda0d92da76ced50fe1d0cc22a1.zip
app-crypt/pinentry: Version bump (v1.1.1)
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/Manifest1
-rw-r--r--app-crypt/pinentry/pinentry-1.1.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/app-crypt/pinentry/Manifest b/app-crypt/pinentry/Manifest
index 96c7370bde23..034a29fa6e0a 100644
--- a/app-crypt/pinentry/Manifest
+++ b/app-crypt/pinentry/Manifest
@@ -1 +1,2 @@
DIST pinentry-1.1.0.tar.bz2 467702 BLAKE2B cf43555848ab0dc60756fca123aba7599ebb1bfe0458b973ed9d84479f8de9ee69ef309b518b40aa340434d64d37793cf97c94f78f99820bc5c71ecd2aac7a49 SHA512 5012672925bcb5f683358c259e55e4b87c67cf063ad52c759308933733025c33f7ce08e5b8019ffc101cbf7ef30499040ef2fd34a7611698e65e1593f80948cd
+DIST pinentry-1.1.1.tar.bz2 515723 BLAKE2B f257fe552852e6d1ff2c23aeb0c1127b43e3a60e44c78dfa764d569e659ccb78528ce3ee863114af273a4b6f6c24686cda2cb14bb04995eb8c41ccd4541a9fbd SHA512 d6ab5af8ac2f3c9c05e09703e95d8e2676f9b2b7ceb97f6a31d101d0e9da7a1e106a6d3eabe86cab1bb35a4b119a7cba1380ac64bf13c61af0b3c48803116c12
diff --git a/app-crypt/pinentry/pinentry-1.1.1.ebuild b/app-crypt/pinentry/pinentry-1.1.1.ebuild
new file mode 100644
index 000000000000..5d2943485111
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-1.1.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic qmake-utils toolchain-funcs
+
+DESCRIPTION="Simple passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="https://gnupg.org/aegypten2/index.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="caps emacs gnome-keyring gtk ncurses qt5"
+
+DEPEND="
+ app-eselect/eselect-pinentry
+ >=dev-libs/libassuan-2.1
+ >=dev-libs/libgcrypt-1.6.3
+ >=dev-libs/libgpg-error-1.17
+ caps? ( sys-libs/libcap )
+ gnome-keyring? ( app-crypt/libsecret )
+ ncurses? ( sys-libs/ncurses:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="${DEPEND}
+ gtk? ( app-crypt/gcr )
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-make-icon-work-under-Plasma-Wayland.patch"
+ "${FILESDIR}/${PN}-0.8.2-ncurses.patch"
+ "${FILESDIR}/${PN}-1.0.0-AR.patch"
+)
+
+src_prepare() {
+ default
+ unset FLTK_CONFIG
+ eautoreconf
+}
+
+src_configure() {
+ [[ "$(gcc-major-version)" -ge 5 ]] && append-cxxflags -std=gnu++11
+
+ export QTLIB="$(qt5_get_libdir)"
+
+ econf \
+ $(use_enable emacs pinentry-emacs) \
+ $(use_enable gnome-keyring libsecret) \
+ $(use_enable gtk pinentry-gnome3) \
+ $(use_enable ncurses fallback-curses) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable qt5 pinentry-qt) \
+ $(use_with caps libcap) \
+ --enable-pinentry-tty \
+ --disable-pinentry-fltk \
+ --disable-pinentry-gtk2 \
+ MOC="$(qt5_get_bindir)"/moc \
+ GPG_ERROR_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-gpg-error-config" \
+ LIBASSUAN_CONFIG="${ESYSROOT}/usr/bin/libassuan-config" \
+ $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
+}
+
+src_install() {
+ default
+ rm "${ED}"/usr/bin/pinentry || die
+
+ use qt5 && dosym pinentry-qt /usr/bin/pinentry-qt5
+}
+
+pkg_postinst() {
+ eselect pinentry update ifunset
+}
+
+pkg_postrm() {
+ eselect pinentry update ifunset
+}