summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/openssl-blacklist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/openssl-blacklist')
-rw-r--r--app-crypt/openssl-blacklist/Manifest2
-rw-r--r--app-crypt/openssl-blacklist/metadata.xml10
-rw-r--r--app-crypt/openssl-blacklist/openssl-blacklist-0.5.3.ebuild52
3 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/openssl-blacklist/Manifest b/app-crypt/openssl-blacklist/Manifest
new file mode 100644
index 000000000000..5cefbb0be831
--- /dev/null
+++ b/app-crypt/openssl-blacklist/Manifest
@@ -0,0 +1,2 @@
+DIST openssl-blacklist_0.5-3.diff.gz 20228 SHA256 caf34380fce6f4b31d958a176f8f5d0a4d1e9da66ceaed2e5a20c7929d341942 SHA512 5e5b7fdc97248ccc44f3ffa306a23f9d3ed9585cee15f1ad55dffcf4e70a50463c05382b393bc07e4bd18ea530eea7d36a508f40c1e03b0932eb3cde43f886bd WHIRLPOOL 4d7dd96e4c0b8ff780d64848cf15e1be9c0c97651b4aeefb502093a4436ab706f23f0399972e8f3fea28413efd7c76964034d335ca1c0a1b23153bbf1d6d8cd5
+DIST openssl-blacklist_0.5.orig.tar.gz 32908393 SHA256 d194cafbbad9ba10b6dd1721ee241c1a645552d206203f764fe4f059b29175bb SHA512 b0ecab15f4357b56508b048a0648263f118aa8eeda8ad6a15caab8c38b2270a5daf897026daf376a561b292c64c2651269182732e0ae3e4bbac455cc1d3985ab WHIRLPOOL dbbcd44db10dba96390ae7d32ca008ce62a43c2764aa582009b4b8d809be8241553cab5a8cb778401b88ad88da1edd1125775d74ada61b73a2d3b812a1ed8b5f
diff --git a/app-crypt/openssl-blacklist/metadata.xml b/app-crypt/openssl-blacklist/metadata.xml
new file mode 100644
index 000000000000..bc1e2719c4da
--- /dev/null
+++ b/app-crypt/openssl-blacklist/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">ubuntu/+source/openssl-blacklist</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/openssl-blacklist/openssl-blacklist-0.5.3.ebuild b/app-crypt/openssl-blacklist/openssl-blacklist-0.5.3.ebuild
new file mode 100644
index 000000000000..204b5ea0919c
--- /dev/null
+++ b/app-crypt/openssl-blacklist/openssl-blacklist-0.5.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils versionator python-single-r1
+
+MY_PV=$(get_version_component_range 1-2)
+MY_P="${PN}-${MY_PV}"
+DEB_P="${PN}_${MY_PV}"
+DEB_PVER=$(get_version_component_range 3)
+DEB_PATCH="${DEB_P}-${DEB_PVER}.diff"
+
+DESCRIPTION="Detection of weak ssl keys produced by certain debian versions between 2006 and 2008"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/openssl-blacklist/"
+SRC_URI="mirror://debian/pool/main/o/${PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/o/${PN}/${DEB_PATCH}.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ EPATCH_OPTS="-p1" epatch "${WORKDIR}"/${DEB_PATCH}
+}
+
+src_install() {
+ dobin openssl-vulnkey
+ doman openssl-vulnkey.1
+ insinto /usr/share/openssl-blacklist
+
+ # ripped from debian/rules "install" target
+ local keysize
+ for keysize in 512 1024 2048 4096 ; do
+ (
+ cat debian/blacklist.prefix
+ cat blacklists/{be32,le32,le64}/blacklist-${keysize}.db \
+ | cut -d ' ' -f 5 | cut -b21- | sort
+ ) > blacklist.RSA-${keysize}
+ doins blacklist.RSA-${keysize}
+ done
+
+ python_fix_shebang "${ED}/usr/bin/openssl-vulnkey"
+}