summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-06-09 12:16:11 -0700
committerZac Medico <zmedico@gentoo.org>2024-06-09 12:25:08 -0700
commit0a34c563fe50f96e4c1fc9aaa71251b9fa1e87e3 (patch)
treed651e82b4b38abc384a5630d11a0cb2e97daf984 /app-crypt/gocryptfs
parentsys-libs/slang: Drop old versions (diff)
downloadgentoo-0a34c563fe50f96e4c1fc9aaa71251b9fa1e87e3.tar.gz
gentoo-0a34c563fe50f96e4c1fc9aaa71251b9fa1e87e3.tar.bz2
gentoo-0a34c563fe50f96e4c1fc9aaa71251b9fa1e87e3.zip
app-crypt/gocryptfs: new package, add 2.4.0
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-crypt/gocryptfs')
-rw-r--r--app-crypt/gocryptfs/Manifest1
-rw-r--r--app-crypt/gocryptfs/gocryptfs-2.4.0.ebuild39
-rw-r--r--app-crypt/gocryptfs/metadata.xml11
3 files changed, 51 insertions, 0 deletions
diff --git a/app-crypt/gocryptfs/Manifest b/app-crypt/gocryptfs/Manifest
new file mode 100644
index 000000000000..6e4250362ab5
--- /dev/null
+++ b/app-crypt/gocryptfs/Manifest
@@ -0,0 +1 @@
+DIST gocryptfs_v2.4.0_src-deps.tar.gz 2927929 BLAKE2B e66e91506c5a7abb5413e8797f786145c436ca760e3c7157590ccb1c8430b2ac240b8ba1fd0ed3401ee4277a2e9ef6b8f3a9b3c52c22bac8e6b27b56350d9eec SHA512 b46d6eee21a0194022a042d6ae2a737f221a0932bb899123438f2cf929ecb50635fcfc90012d6a04928fd4b2856d6e24d19392ce5aa87eea573fb58cf5a5d4e1
diff --git a/app-crypt/gocryptfs/gocryptfs-2.4.0.ebuild b/app-crypt/gocryptfs/gocryptfs-2.4.0.ebuild
new file mode 100644
index 000000000000..1097ebdaab4d
--- /dev/null
+++ b/app-crypt/gocryptfs/gocryptfs-2.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Encrypted overlay filesystem written in Go"
+HOMEPAGE="https://github.com/rfjakob/gocryptfs"
+SRC_URI="https://github.com/rfjakob/gocryptfs/releases/download/v${PV}/${PN}_v${PV}_src-deps.tar.gz"
+S=${WORKDIR}/${PN}_v${PV}_src-deps
+LICENSE="MIT"
+LICENSE+=" Apache-2.0 BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+BDEPEND="virtual/pandoc"
+PROPERTIES="test_privileged"
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -e 's:ldd gocryptfs 2> /dev/null:! ldd gocryptfs | grep -q "statically linked":' \
+ -i "${S}/build-without-openssl.bash" || die
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ emake "DESTDIR=${ED}" install
+ dobin contrib/statfs/statfs
+ doman Documentation/*.1
+ dodoc -r README.md Documentation
+ rm -f "${ED}"/usr/share/doc/${PF}/Documentation/{.gitignore,gocryptfs.1,gocryptfs-xray.1,statfs.1,MANPAGE-render.bash} || die
+}
+
+src_test() {
+ emake test
+}
diff --git a/app-crypt/gocryptfs/metadata.xml b/app-crypt/gocryptfs/metadata.xml
new file mode 100644
index 000000000000..9dddd0e70502
--- /dev/null
+++ b/app-crypt/gocryptfs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rfjakob/gocryptfs</remote-id>
+ </upstream>
+</pkgmetadata>