summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-08 14:19:28 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-08 14:19:28 +0200
commitdaa0cdd305b3845c038b9152b5798003b569e497 (patch)
treeddd4ebfcc31259088d45965e0de5a541fe7e89c3 /app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild
parentdev-util/drone: Remove old (diff)
downloadgentoo-daa0cdd305b3845c038b9152b5798003b569e497.tar.gz
gentoo-daa0cdd305b3845c038b9152b5798003b569e497.tar.bz2
gentoo-daa0cdd305b3845c038b9152b5798003b569e497.zip
app-crypt/cfssl: Update snapshot
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild')
-rw-r--r--app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild b/app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild
new file mode 100644
index 000000000000..febb491cd702
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.2.0_p20170601.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/cloudflare/${PN}"
+EGIT_COMMIT="9c06c53d4dfb9c0272c983a26ea10a6a2da12392"
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ pushd src || die
+ GOPATH="${S}" go install github.com/cloudflare/cfssl/cmd/... || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ pushd src/${EGO_PN} || die
+ dodoc CHANGELOG README.md
+ popd || die
+}