summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-02 16:24:23 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-02 17:01:02 +0200
commit95baf76d1d157f36e6e6cd449202638ec70a6c7b (patch)
treec53cf92cdf8003ab52b65a1d43577d1783d7f26f /app-containers
parentapp-containers/distrobox: drop old 1.7.0.1 (diff)
downloadgentoo-95baf76d1d157f36e6e6cd449202638ec70a6c7b.tar.gz
gentoo-95baf76d1d157f36e6e6cd449202638ec70a6c7b.tar.bz2
gentoo-95baf76d1d157f36e6e6cd449202638ec70a6c7b.zip
app-containers/distrobox: bump to 1.7.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/distrobox/Manifest1
-rw-r--r--app-containers/distrobox/distrobox-1.7.2.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index ec14917610ad..b196849b263e 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1 +1,2 @@
DIST distrobox-1.7.1.tar.gz 6885484 BLAKE2B c4b2710d7f1cff7baee2e340a79345359e9906e508e8b1bc351a7b8ee2d8d2e1cb13c381e40231f8c962542e37e32988d04a687810bdfd7ec917868944c51cf3 SHA512 a86a49b9f6158af3172369a201ce3852a349258c46ebb8dfb269f7b96dfbe2bf2fe9f80a5cf9b9236432d99f4f67fb3d95ab4663964fcdb0f888d48cbdd82c39
+DIST distrobox-1.7.2.0.tar.gz 6888905 BLAKE2B f74301464f3b590f246871be1a381771e0fccbd42a933b9d2a58874eb97e49ae73676f7267b56dc7facefdba6cac1fc3df52d55ef826c0d79c90bbe9e0955af7 SHA512 ae5c9ef7ee63beec6b99488091cdb5bc73dfb219988a71c624af2278ea2efc775895ae2106c6bc35783a317b5b3e92fceed2fdba5be05f94028d28a7a2fb8ce1
diff --git a/app-containers/distrobox/distrobox-1.7.2.0.ebuild b/app-containers/distrobox/distrobox-1.7.2.0.ebuild
new file mode 100644
index 000000000000..0a328c47011d
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.7.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.it/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}