summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-17 14:46:19 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-17 15:39:33 +0200
commit3645911226964f28331e4658d817d0480ca9d68e (patch)
treedafdf23f87bd3c52d8986da36cdf2f3039b215e2 /app-containers/devcontainer
parentsci-electronics/nvc: bump to 1.10.4 (diff)
downloadgentoo-3645911226964f28331e4658d817d0480ca9d68e.tar.gz
gentoo-3645911226964f28331e4658d817d0480ca9d68e.tar.bz2
gentoo-3645911226964f28331e4658d817d0480ca9d68e.zip
app-containers/devcontainer: bump to 0.52.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers/devcontainer')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.52.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index 1fbeab3ea9cc..8744645c47b7 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1 +1,2 @@
DIST devcontainer-0.52.0.tgz 614149 BLAKE2B 1e71d4772ec799cf8709d1d350cb8db0ea61dd2c7e96be4d35555675f9784bb1ff71ba95b6816fa9f8b6bd62c9a2b801871d51ab9fd8b564052c5939be603e2f SHA512 1790c6f2933c343b17a52d87a065e78c6e90b59249efb14c4601fc39de9a89aa6a93d100664ad3180a779c01fc181a31e59026af6bd646c214a616c61aed634c
+DIST devcontainer-0.52.1.tgz 614268 BLAKE2B e1e2979e7d105e0082db4019260b7015c6bab9899f43e75ff1246f879bd659557404ca2f10ffa021bd5cf2caaff6f0dad53ca8b8c48e7f082d00961c9982faf0 SHA512 b182b57071c356374121dc63301f0eebaf3ea9fd0000424f31b78c47d6536d4cd74013647bcf2f50e67a0c3f528eca9e1397acf12a565fa8d5ea0688b73245c8
diff --git a/app-containers/devcontainer/devcontainer-0.52.1.ebuild b/app-containers/devcontainer/devcontainer-0.52.1.ebuild
new file mode 100644
index 000000000000..399665b46cde
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.52.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}