summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 20:14:14 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:54:55 +0100
commit2fa9e4068bb6b9bcdaf723751714a60608a12a46 (patch)
tree2b74cbcfcdf0a746a6e5880326cfefa762798d18 /app-benchmarks
parentapp-admin/dio: drop 1.5.2-r2 (diff)
downloadgentoo-2fa9e4068bb6b9bcdaf723751714a60608a12a46.tar.gz
gentoo-2fa9e4068bb6b9bcdaf723751714a60608a12a46.tar.bz2
gentoo-2fa9e4068bb6b9bcdaf723751714a60608a12a46.zip
app-benchmarks/cpuburn: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a-r4.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a-r4.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a-r4.ebuild
new file mode 100644
index 000000000000..7c532a610978
--- /dev/null
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a-r4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/./_}"
+
+DESCRIPTION="CPU testing utilities in optimized assembler for maximum loading"
+HOMEPAGE="https://web.archive.org/web/20110623074500/pages.sbcglobal.net/redelm/"
+SRC_URI="https://dev.gentoo.org/~conikost/files/${PN}_${MY_PV}_tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="-* amd64 arm x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${P}-variables.patch" )
+
+QA_FLAGS_IGNORED="
+ usr/bin/burnBX
+ usr/bin/burnK6
+ usr/bin/burnK7
+ usr/bin/burnMMX
+ usr/bin/burnP5
+ usr/bin/burnP6
+"
+
+QA_TEXTRELS="${QA_FLAGS_IGNORED}"
+
+src_prepare() {
+ default
+
+ # Respect users compiler and users CFLAGS and LDFLAGS on x86/amd64
+ # Must be always compiled in 32-bit on amd64 arch
+ # See https://bugs.gentoo.org/65719
+ sed -i -e 's/gcc -s/$(CC) $(CFLAGS) -m32 $(LDFLAGS)/' Makefile || die
+
+ # Respect users compiler, CFLAGS and LDFLAGS on arm
+ sed -i -e '/CC :=/d' -e 's/^.*-mfloat-abi=softfp/ $(CC) $(CFLAGS) -nostdlib $(LDFLAGS)/' ARM/Makefile || die
+}
+
+src_compile() {
+ if use arm; then
+ cd "${S}"/ARM || die
+ fi
+
+ default
+}
+
+src_install() {
+ if use arm; then
+ dobin ARM/burnCortexA8 ARM/burnCortexA9
+ local DOCS=( "ARM/Design" "README" )
+ else
+ dobin burnBX burnK6 burnK7 burnMMX burnP5 burnP6
+ local DOCS=( "Design" "README" )
+ fi
+
+ einstalldocs
+}