summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-03 08:34:37 +0100
committerSam James <sam@gentoo.org>2024-06-03 08:35:18 +0100
commit3c28370d267d655a11b6ee75d74e36510ee1c161 (patch)
tree130e3c11a5e57bb0897f6ce676844e156f8f7761 /app-backup
parentapp-backup/backintime: enable py3.12 (diff)
downloadgentoo-3c28370d267d655a11b6ee75d74e36510ee1c161.tar.gz
gentoo-3c28370d267d655a11b6ee75d74e36510ee1c161.tar.bz2
gentoo-3c28370d267d655a11b6ee75d74e36510ee1c161.zip
app-backup/backintime: add 1.4.3
Also, switch USE=qt5 -> USE=gui per QA policy. Closes: https://bugs.gentoo.org/933388 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/backintime/Manifest1
-rw-r--r--app-backup/backintime/backintime-1.4.3.ebuild105
-rw-r--r--app-backup/backintime/backintime-9999.ebuild18
-rw-r--r--app-backup/backintime/files/backintime-1.4.3-no-compress-docs-examples.patch120
4 files changed, 236 insertions, 8 deletions
diff --git a/app-backup/backintime/Manifest b/app-backup/backintime/Manifest
index b5b693408960..1fc3565c4733 100644
--- a/app-backup/backintime/Manifest
+++ b/app-backup/backintime/Manifest
@@ -1 +1,2 @@
DIST backintime-1.3.3.tar.gz 751422 BLAKE2B 5c6723d1b190c5331b8453d4cf2b14e00a4bb64777d73e3b2a1405be51ebc5418f749fca654032154f1cec2389efcd41e52c571c1f9f1f982bbd0adcb0b7dd59 SHA512 f91157133166869665c8d7475c870cd5418135e17f5e7c8ae5788eb8cd3be39e8ea3d7652aa5945f64d9906b6baed0ed3ee16eb46b81a088210459333efe9372
+DIST backintime-1.4.3.tar.gz 1900866 BLAKE2B ee9f389a7995e0ca059dab7f94ce59b2a0285bc213ffa2fcdc2d3ed2b9920762c16beb0c2d961ac922837c55fa30e1ce27a9de26c6ad0e879f5c70e876644298 SHA512 d5470590d9807c5f4c1c6f46062465ecac9432831f15d1948a95b3f7ba06015939eb292bbb53d2f039ef9e967a93b6bea0e08b928a009370995d0cc2db1f7fdf
diff --git a/app-backup/backintime/backintime-1.4.3.ebuild b/app-backup/backintime/backintime-1.4.3.ebuild
new file mode 100644
index 000000000000..80c960450f88
--- /dev/null
+++ b/app-backup/backintime/backintime-1.4.3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-single-r1 xdg
+
+DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
+HOMEPAGE="https://backintime.readthedocs.io/en/latest/ https://github.com/bit-team/backintime/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/bit-team/backintime/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/bit-team/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples gui test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/openssh
+ net-misc/rsync[xattr,acl]
+ gui? ( dev-python/PyQt5[gui,widgets] )
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.3-no-compress-docs-examples.patch"
+)
+
+src_prepare() {
+ default
+
+ # Looks at host system too much, so too flaky
+ rm common/test/test_tools.py || die
+ # Fails with dbus/udev issue (likely sandbox)
+ rm common/test/test_snapshots.py || die
+}
+
+src_configure() {
+ pushd common > /dev/null || die
+ # Not autotools
+ ./configure --python="${PYTHON}" --no-fuse-group || die
+ popd > /dev/null || die
+
+ if use gui ; then
+ pushd qt > /dev/null || die
+ ./configure --python="${PYTHON}" || die
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ emake -C common
+
+ if use gui ; then
+ emake -C qt
+ fi
+}
+
+src_test() {
+ # pytest should work but it can't find the backintime binary, so
+ # use the unittest-based runner instead.
+ # https://github.com/bit-team/backintime/blob/dev/CONTRIBUTING.md#how-to-contribute-to-back-in-time
+ emake -C common test-v
+}
+
+src_install() {
+ emake -C common DESTDIR="${D}" install
+
+ if use gui ; then
+ emake -C qt DESTDIR="${D}" install
+ fi
+
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc common/{config-example-local,config-example-ssh}
+ fi
+
+ python_optimize "${D}"
+}
diff --git a/app-backup/backintime/backintime-9999.ebuild b/app-backup/backintime/backintime-9999.ebuild
index 27931eda4e24..80c960450f88 100644
--- a/app-backup/backintime/backintime-9999.ebuild
+++ b/app-backup/backintime/backintime-9999.ebuild
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="examples qt5 test"
+IUSE="examples gui test"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -35,7 +35,7 @@ RDEPEND="
${DEPEND}
virtual/openssh
net-misc/rsync[xattr,acl]
- qt5? ( dev-python/PyQt5[gui,widgets] )
+ gui? ( dev-python/PyQt5[gui,widgets] )
"
BDEPEND="
sys-devel/gettext
@@ -46,7 +46,9 @@ BDEPEND="
)
"
-PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.3-no-compress-docs-examples.patch"
+)
src_prepare() {
default
@@ -60,12 +62,12 @@ src_prepare() {
src_configure() {
pushd common > /dev/null || die
# Not autotools
- ./configure --python3 --no-fuse-group || die
+ ./configure --python="${PYTHON}" --no-fuse-group || die
popd > /dev/null || die
- if use qt5 ; then
+ if use gui ; then
pushd qt > /dev/null || die
- ./configure --python3 || die
+ ./configure --python="${PYTHON}" || die
popd > /dev/null || die
fi
}
@@ -73,7 +75,7 @@ src_configure() {
src_compile() {
emake -C common
- if use qt5 ; then
+ if use gui ; then
emake -C qt
fi
}
@@ -88,7 +90,7 @@ src_test() {
src_install() {
emake -C common DESTDIR="${D}" install
- if use qt5 ; then
+ if use gui ; then
emake -C qt DESTDIR="${D}" install
fi
diff --git a/app-backup/backintime/files/backintime-1.4.3-no-compress-docs-examples.patch b/app-backup/backintime/files/backintime-1.4.3-no-compress-docs-examples.patch
new file mode 100644
index 000000000000..9844f349b85e
--- /dev/null
+++ b/app-backup/backintime/files/backintime-1.4.3-no-compress-docs-examples.patch
@@ -0,0 +1,120 @@
+--- a/common/configure
++++ b/common/configure
+@@ -161,7 +161,7 @@ printf "DEST=\$(DESTDIR)\$(PREFIX)\n\n" >> ${MAKEFILE}
+
+ printf "all:\tbuild\n\n" >> ${MAKEFILE}
+
+-printf "build:\ttranslate compress\n\n" >> ${MAKEFILE}
++printf "build:\ttranslate\n\n" >> ${MAKEFILE}
+
+ printf "clean:\n" >> ${MAKEFILE}
+ printf "\trm -f po/*.mo\n" >> ${MAKEFILE}
+@@ -189,30 +189,11 @@ addInstallFiles "plugins/*.py" "/share/backintime/plugins"
+ addUninstallDir "/share/backintime"
+ addNewline
+
+-addComment "documentation"
+-addInstallDir "/share/doc/backintime-common"
+-addInstallFile "../debian/copyright" "/share/doc/backintime-common"
+-addInstallFile "../AUTHORS" "/share/doc/backintime-common"
+-addInstallFile "../LICENSE" "/share/doc/backintime-common"
+-addInstallFile "../README.md" "/share/doc/backintime-common"
+-addInstallFile "../TRANSLATIONS" "/share/doc/backintime-common"
+-addInstallFile "../VERSION" "/share/doc/backintime-common"
+-addInstallFile "../CHANGES" "/share/doc/backintime-common"
+-addNewline
+-
+-addComment "config-examples"
+-addInstallDir "/share/doc/backintime-common/examples"
+-addInstallFile "config-example-local.gz" "/share/doc/backintime-common/examples"
+-addInstallFile "config-example-ssh.gz" "/share/doc/backintime-common/examples"
+-addUninstallDir "/share/doc/backintime-common"
+-addUninstallDir "/share/doc"
+-addNewline
+-
+ addComment "man"
+ addInstallDir "/share/man/man1"
+-addInstallFile "man/C/backintime.1.gz" "/share/man/man1"
+-addInstallFile "man/C/backintime-askpass.1.gz" "/share/man/man1"
+-addInstallFile "man/C/backintime-config.1.gz" "/share/man/man1"
++addInstallFile "man/C/backintime.1" "/share/man/man1"
++addInstallFile "man/C/backintime-askpass.1" "/share/man/man1"
++addInstallFile "man/C/backintime-config.1" "/share/man/man1"
+ addUninstallDir "/share/man"
+ addNewline
+
+@@ -236,16 +217,6 @@ addSymlink "backintime" "/share/bash-completion/completions/backinti
+ addUninstallDir "/share/bash-completion"
+ addNewline
+
+-#compress
+-printf "compress:\n" >> ${MAKEFILE}
+-printf "\t#man pages\n" >> ${MAKEFILE}
+-printf "\tfor i in \$\$(ls -1 man/C/); do case \$\$i in *.gz|*~) continue;; *) gzip -n --best -c man/C/\$\$i > man/C/\$\${i}.gz;; esac; done\n\n" >> ${MAKEFILE}
+-
+-printf "\t#config-examples\n" >> ${MAKEFILE}
+-printf "\tgzip -n --best -c config-example-local > config-example-local.gz\n" >> ${MAKEFILE}
+-printf "\tgzip -n --best -c config-example-ssh > config-example-ssh.gz\n\n" >> ${MAKEFILE}
+-
+-#translate
+ printf "translate:\t$mos\n\n" >> ${MAKEFILE}
+
+ for lang in $langs; do
+--- a/qt/configure
++++ b/qt/configure
+@@ -138,7 +138,7 @@ printf "DEST=\$(DESTDIR)\$(PREFIX)\n\n" >> ${MAKEFILE}
+
+ printf "all:\tbuild\n\n" >> ${MAKEFILE}
+
+-printf "build:\tcompress\n\n" >> ${MAKEFILE}
++printf "build:\n\n" >> ${MAKEFILE}
+
+ printf "clean:\n" >> ${MAKEFILE}
+ printf "\trm -f po/*.mo\n" >> ${MAKEFILE}
+@@ -149,7 +149,6 @@ printf "install:\n" >> ${MAKEFILE}
+
+ # Migration
+ printf "\t#clean-up installed old files that were renamed or moved in later BiT versions\n" >> ${MAKEFILE}
+-printf "\trm -f /etc/dbus-1/system.d/net.launchpad.backintime.serviceHelper.conf\n" >> ${MAKEFILE}
+ printf "\trm -f \$(DEST)/share/backintime/plugins/qt4plugin.py\n" >> ${MAKEFILE}
+ addNewline
+
+@@ -193,17 +192,6 @@ addInstallFiles "net.launchpad.backintime*.policy" "/share/polkit-1/actions"
+ addUninstallDir "/share/polkit-1"
+ addNewline
+
+-addComment "documentation"
+-addInstallDir "/share/doc/backintime-qt"
+-addInstallFile "../debian/copyright" "/share/doc/backintime-qt"
+-addInstallFile "../AUTHORS" "/share/doc/backintime-qt"
+-addInstallFile "../LICENSE" "/share/doc/backintime-qt"
+-addInstallFile "../README.md" "/share/doc/backintime-qt"
+-addInstallFile "../TRANSLATIONS" "/share/doc/backintime-qt"
+-addInstallFile "../VERSION" "/share/doc/backintime-qt"
+-addInstallFile "../CHANGES" "/share/doc/backintime-qt"
+-addNewline
+-
+ addComment ".desktop"
+ addInstallDir "/share/applications"
+ addInstallFiles "*.desktop" "/share/applications"
+@@ -211,7 +199,7 @@ addNewline
+
+ addComment "man"
+ addInstallDir "/share/man/man1"
+-addInstallFile "man/C/backintime-qt.1.gz" "/share/man/man1"
++addInstallFile "man/C/backintime-qt.1" "/share/man/man1"
+ addUninstallDir "/share/man"
+ addNewline
+
+@@ -226,11 +214,6 @@ addUninstallDir "/share/icons"
+ addUninstallDir "/share"
+ addNewline
+
+-#compress
+-printf "compress:\n" >> ${MAKEFILE}
+-printf "\t#man pages\n" >> ${MAKEFILE}
+-printf "\tfor i in \$\$(ls -1 man/C/); do case \$\$i in *.gz|*~) continue;; *) gzip -n --best -c man/C/\$\$i > man/C/\$\${i}.gz;; esac; done\n\n" >> ${MAKEFILE}
+-
+ #uninstall
+ printf "uninstall: uninstall_files uninstall_dirs\n\n" >> ${MAKEFILE}
+ printf "uninstall_files:\n" >> ${MAKEFILE}