summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-06-01 12:55:04 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-06-01 12:57:38 -0500
commitd4beb2fa6cfa708c53fdcebab03a18559704e611 (patch)
tree81695dab1a4d3c3ef330320e9fc5de6d2279bac4 /app-backup/consul-backinator/consul-backinator-1.6.5.ebuild
parentqt5-build.eclass: use safer '|' sed delimiter, not ':' (diff)
downloadgentoo-d4beb2fa6cfa708c53fdcebab03a18559704e611.tar.gz
gentoo-d4beb2fa6cfa708c53fdcebab03a18559704e611.tar.bz2
gentoo-d4beb2fa6cfa708c53fdcebab03a18559704e611.zip
app-backup/consul-backinator: consul backup and restore utility
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-backup/consul-backinator/consul-backinator-1.6.5.ebuild')
-rw-r--r--app-backup/consul-backinator/consul-backinator-1.6.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-backup/consul-backinator/consul-backinator-1.6.5.ebuild b/app-backup/consul-backinator/consul-backinator-1.6.5.ebuild
new file mode 100644
index 000000000000..d74bd040c727
--- /dev/null
+++ b/app-backup/consul-backinator/consul-backinator-1.6.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/myENA/consul-backinator
+RESTRICT="strip"
+
+DESCRIPTION="consul backup and restore utility"
+HOMEPAGE="https://github.com/myENA/consul-backinator"
+SRC_URI="https://github.com/myENA/consul-backinator/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-lang/go:="
+
+src_prepare() {
+ default
+ mv ../vendor .
+ echo module ${EGO_PN} > go.mod || die "Unable to create go.mod"
+}
+
+src_compile() {
+ CGO_ENABLED=0 go build -mod vendor -o "${PN}" -v -x \
+ -ldflags="-X main.appVersion=${PV} -s -w" || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.md
+}