summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-09 12:04:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-09 12:04:42 +0200
commitc95df977cbb4d26802beb376b1004659593e53b6 (patch)
tree8224b378160fa0c010d850fe0abf48a8bc253656 /app-arch
parentsys-kernel/gentoo-sources: Stabilize 5.15.72 x86, #876229 (diff)
downloadgentoo-c95df977cbb4d26802beb376b1004659593e53b6.tar.gz
gentoo-c95df977cbb4d26802beb376b1004659593e53b6.tar.bz2
gentoo-c95df977cbb4d26802beb376b1004659593e53b6.zip
app-arch/lz4: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lz4/Manifest1
-rw-r--r--app-arch/lz4/files/lz4-1.9.3-negative-memmove.patch22
-rw-r--r--app-arch/lz4/lz4-1.9.3-r1.ebuild30
3 files changed, 0 insertions, 53 deletions
diff --git a/app-arch/lz4/Manifest b/app-arch/lz4/Manifest
index 835409a3a225..dfd1e824e657 100644
--- a/app-arch/lz4/Manifest
+++ b/app-arch/lz4/Manifest
@@ -1,2 +1 @@
-DIST lz4-1.9.3.tar.gz 320958 BLAKE2B 9a194bd18ff52f780aa03a8a53fe7fab7b58117d768f4ba8e5005830c935d16328d0f7cc54f9413b58faf245017c0ac85fb4e709a9db150cb150a0a2a3c21645 SHA512 c246b0bda881ee9399fa1be490fa39f43b291bb1d9db72dba8a85db1a50aad416a97e9b300eee3d2a4203c2bd88bda2762e81bc229c3aa409ad217eb306a454c
DIST lz4-1.9.4.tar.gz 354063 BLAKE2B 2289cdce36acd35283bf2f02ef4d6d8f4805563be6d5a3492f3d6ea7975fb6bd14e1ac2e505df9747776edf8bcf0da7ba4ae7084b150e3ec08a52a9885f92ad5 SHA512 043a9acb2417624019d73db140d83b80f1d7c43a6fd5be839193d68df8fd0b3f610d7ed4d628c2a9184f7cde9a0fd1ba9d075d8251298e3eb4b3a77f52736684
diff --git a/app-arch/lz4/files/lz4-1.9.3-negative-memmove.patch b/app-arch/lz4/files/lz4-1.9.3-negative-memmove.patch
deleted file mode 100644
index 053958dfe872..000000000000
--- a/app-arch/lz4/files/lz4-1.9.3-negative-memmove.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 8301a21773ef61656225e264f4f06ae14462bca7 Mon Sep 17 00:00:00 2001
-From: Jasper Lievisse Adriaanse <j@jasper.la>
-Date: Fri, 26 Feb 2021 15:21:20 +0100
-Subject: [PATCH] Fix potential memory corruption with negative memmove() size
-
----
- lib/lz4.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/lz4.c b/lib/lz4.c
-index 5f524d01d..c2f504ef3 100644
---- a/lib/lz4.c
-+++ b/lib/lz4.c
-@@ -1749,7 +1749,7 @@ LZ4_decompress_generic(
- const size_t dictSize /* note : = 0 if noDict */
- )
- {
-- if (src == NULL) { return -1; }
-+ if ((src == NULL) || (outputSize < 0)) { return -1; }
-
- { const BYTE* ip = (const BYTE*) src;
- const BYTE* const iend = ip + srcSize;
diff --git a/app-arch/lz4/lz4-1.9.3-r1.ebuild b/app-arch/lz4/lz4-1.9.3-r1.ebuild
deleted file mode 100644
index b2070d474c30..000000000000
--- a/app-arch/lz4/lz4-1.9.3-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-DESCRIPTION="Extremely Fast Compression algorithm"
-HOMEPAGE="https://github.com/lz4/lz4"
-SRC_URI="https://github.com/lz4/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2 GPL-2"
-# https://abi-laboratory.pro/tracker/timeline/lz4/
-SLOT="0/r132"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="static-libs"
-
-CMAKE_USE_DIR=${S}/build/cmake
-
-PATCHES=(
- "${FILESDIR}"/${P}-negative-memmove.patch
-)
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_STATIC_LIBS=$(usex static-libs)
- )
-
- cmake_src_configure
-}