summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:06 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:06 +0200
commite6ef88c4ce96c90cfb0a0ed891265880e20b4e78 (patch)
tree7df35a11ede8473fd246cf39ae0b0e35f45ffed3 /app-arch/pxz/pxz-5.0_pre20151029-r1.ebuild
parentxfce-base/garcon: Bump to 4.17.0 (diff)
downloadgentoo-e6ef88c4ce96c90cfb0a0ed891265880e20b4e78.tar.gz
gentoo-e6ef88c4ce96c90cfb0a0ed891265880e20b4e78.tar.bz2
gentoo-e6ef88c4ce96c90cfb0a0ed891265880e20b4e78.zip
app-arch/pxz: [QA] use tc-check-openmp correctly
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-arch/pxz/pxz-5.0_pre20151029-r1.ebuild')
-rw-r--r--app-arch/pxz/pxz-5.0_pre20151029-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/pxz/pxz-5.0_pre20151029-r1.ebuild b/app-arch/pxz/pxz-5.0_pre20151029-r1.ebuild
new file mode 100644
index 000000000000..c9ad43cebe99
--- /dev/null
+++ b/app-arch/pxz/pxz-5.0_pre20151029-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Parallel implementation of the XZ compression utility"
+HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
+SRC_URI="https://github.com/jnovy/pxz/archive/fcfea93957d96b7661d1439cf4b767ecfd341eed.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux"
+
+# needs the library from xz-utils
+RDEPEND="app-arch/xz-utils"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+}
+
+src_prepare() {
+ default
+
+ if use elibc_musl ; then
+ sed -i -e '/<error.h>/c\#define error(R,E,S,...) fprintf(stderr, S "\\n", ##__VA_ARGS__); exit(R)' pxz.c || die
+ fi
+}
+
+src_configure() {
+ tc-export CC
+ export BINDIR="${EPREFIX}"/usr/bin
+ export MANDIR="${EPREFIX}"/usr/share/man
+}