summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 19:12:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 19:12:36 +0100
commitc68c017ca4538afcb9267e283efe453528977eb1 (patch)
tree30d8bec35aeb1727c385c09b13ad9ac1623027e9 /app-arch/plzip/plzip-1.10.ebuild
parentapp-arch/lzlib: Bump to 1.13 (diff)
downloadgentoo-c68c017ca4538afcb9267e283efe453528977eb1.tar.gz
gentoo-c68c017ca4538afcb9267e283efe453528977eb1.tar.bz2
gentoo-c68c017ca4538afcb9267e283efe453528977eb1.zip
app-arch/plzip: Bump to 1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/plzip/plzip-1.10.ebuild')
-rw-r--r--app-arch/plzip/plzip-1.10.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/plzip/plzip-1.10.ebuild b/app-arch/plzip/plzip-1.10.ebuild
new file mode 100644
index 000000000000..e28408c9f42f
--- /dev/null
+++ b/app-arch/plzip/plzip-1.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Parallel lzip compressor"
+HOMEPAGE="https://www.nongnu.org/lzip/plzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/lzlib:0="
+DEPEND=${RDEPEND}
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CXX="$(tc-getCXX)"
+ CPPFLAGS="${CPPFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}