summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-11-16 19:20:21 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-11-16 19:20:58 +0100
commit6fe46654284f96df0599855e50d8ae6b3dcf125b (patch)
tree5f2ff5c51dac1f53d132d53ca2dc080e1ac29eb6 /app-arch/mscompress
parentdev-libs/dmalloc: GetEnvironmentVariableA implicit in configure is ok (diff)
downloadgentoo-6fe46654284f96df0599855e50d8ae6b3dcf125b.tar.gz
gentoo-6fe46654284f96df0599855e50d8ae6b3dcf125b.tar.bz2
gentoo-6fe46654284f96df0599855e50d8ae6b3dcf125b.zip
app-arch/mscompress: add eautoreconf to fix configure
Closes: https://bugs.gentoo.org/906001 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-arch/mscompress')
-rw-r--r--app-arch/mscompress/mscompress-0.3-r2.ebuild (renamed from app-arch/mscompress/mscompress-0.3-r1.ebuild)11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-arch/mscompress/mscompress-0.3-r1.ebuild b/app-arch/mscompress/mscompress-0.3-r2.ebuild
index eb684b82abbc..d2ca43f04369 100644
--- a/app-arch/mscompress/mscompress-0.3-r1.ebuild
+++ b/app-arch/mscompress/mscompress-0.3-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs autotools
DESCRIPTION="Microsoft compress.exe/expand.exe compatible (de)compressor"
HOMEPAGE="https://gnuwin32.sourceforge.net/packages/mscompress.htm"
@@ -18,6 +18,11 @@ PATCHES=(
"${FILESDIR}"/${P}-amd64.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
tc-export CC
[[ $(tc-arch) == ppc* ]] && append-flags -fsigned-char