summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2021-06-09 14:13:02 -0400
committerMike Frysinger <vapier@gentoo.org>2021-06-09 14:14:53 -0400
commit5c8762365232d30709fda8bb33ea08b731cfddad (patch)
tree39ffcfbc77b6d839d98a7813bc8189a538397e1b /app-arch/lbzip2
parentapp-arch/pbzip2: update to EAPI=7 #756880 (diff)
downloadgentoo-5c8762365232d30709fda8bb33ea08b731cfddad.tar.gz
gentoo-5c8762365232d30709fda8bb33ea08b731cfddad.tar.bz2
gentoo-5c8762365232d30709fda8bb33ea08b731cfddad.zip
app-arch/lbzip2: add USE=static support
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'app-arch/lbzip2')
-rw-r--r--app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild b/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild
index ab756306f95b..e8d3af562b38 100644
--- a/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild
+++ b/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Parallel bzip2 utility"
HOMEPAGE="https://github.com/kjn/lbzip2/"
@@ -12,7 +12,7 @@ SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="debug symlink"
+IUSE="debug static symlink"
RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
DEPEND=""
@@ -28,6 +28,8 @@ src_prepare() {
}
src_configure() {
+ use static && append-ldflags -static
+
local myeconfargs=(
$(use_enable debug tracing)
)