summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-23 08:54:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-23 09:58:39 +0100
commitef9e76946b685c937b93e105511d842fe463e6d4 (patch)
tree7409c817f32a560c9fe98f2e106a8feba14e71e1 /app-admin
parentdev-python/boto3: Bump to 1.21.24 (diff)
downloadgentoo-ef9e76946b685c937b93e105511d842fe463e6d4.tar.gz
gentoo-ef9e76946b685c937b93e105511d842fe463e6d4.tar.bz2
gentoo-ef9e76946b685c937b93e105511d842fe463e6d4.zip
app-admin/awscli: Bump to 1.22.79
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.79.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 8d711208d162..3a08c539dafd 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -7,3 +7,4 @@ DIST awscli-1.22.75.tar.gz 2179099 BLAKE2B 697c02e6981213cd6694d1d4f988148488ba4
DIST awscli-1.22.76.tar.gz 2179831 BLAKE2B 4c1bf344a7e21dbe3e96cade9aa5f2efcabe969ebd7804a05b6ba361a2dc11c9f07786198923fefed419b425dc7e4d469a9683474a30495f399e39e9cee8f15c SHA512 bf4971e1d92294901f273891d6e2d2ae2c142842df3fe09391d5f12672f2504ddcc3b467db82439dba434f2e50c4a529c5141366b34ec9722e9ad9705ace5f09
DIST awscli-1.22.77.tar.gz 2179996 BLAKE2B fec49002841fa634bd2b7ae72f534bda875d69169179bbeb85eac18f2d9e9102121b6c0d73d8c7132ac0a6b8e5a8a39cea258d90c15f90b29b44d12ed509cfd1 SHA512 0fa89b6a2dd9dfc7e7be713c10b7470ad8fe8877a7fa9712510254cfbef36771f9e2541adfef9366e13e2273a373c2b88730572f7f1ad79c19f67e57c17e6631
DIST awscli-1.22.78.tar.gz 2180430 BLAKE2B 72d922665a90d4ce504e62324490cd8263c35279fee561618dfb05bf0b3aec51a494df8230bd954866e74835fbb40693af66911aae83661c4049223945d0d948 SHA512 b181146f5b11303959350d2a93d01697ac7e9e2acbf74c46ea8e42d5bd97401046a8bd589ee01042d0741caf0fff188dd2e2d202ed6c50ac33b28971910f0af6
+DIST awscli-1.22.79.tar.gz 2180881 BLAKE2B e933f2d0c8740f19aa060f33df8d2b7d329046afc3ec65feb5c2663241268c52a84dd7935dd7303f3ad1dd9ca88b179a04cd1ab085ece5edd8991cbb8528ff75 SHA512 63b3d6138e9caabe22aeee8d2875830a3bbfe5bfcc649616478ba43f11948bff7e41800663a9be96bad99bab56820f644ba6056aa233869ef00ac20f1657ef6b
diff --git a/app-admin/awscli/awscli-1.22.79.ebuild b/app-admin/awscli/awscli-1.22.79.ebuild
new file mode 100644
index 000000000000..2040c8cb81d2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.79.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}