summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-16 03:59:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-16 05:18:01 +0200
commit89ddf71827387d9257bf7150b7ce44d27760221c (patch)
tree466c40439a92ee87ac7f85575161c96b7c5f4527 /app-admin
parentdev-python/boto3: Bump to 1.34.162 (diff)
downloadgentoo-89ddf71827387d9257bf7150b7ce44d27760221c.tar.gz
gentoo-89ddf71827387d9257bf7150b7ce44d27760221c.tar.bz2
gentoo-89ddf71827387d9257bf7150b7ce44d27760221c.zip
app-admin/awscli: Bump to 1.33.44
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.33.44.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 55a5b4d85250..463ff0720b30 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.33.40.gh.tar.gz 2769444 BLAKE2B a26e26cb4694460e36fe2d9730092db33
DIST aws-cli-1.33.41.gh.tar.gz 2769886 BLAKE2B fa6ea3d7349b1fb5a7ed4e0d8a4b2dcec717d97c471976ee57637552939e0af5b6ed2d7577a73dedb51a2dce634920ee7413178390047e58d00a5d48592fbcbf SHA512 82efb569286f5dd64b6d63b177224eab389713b9a6b81c928b471df91d65bac70fa9931de49f3f776c4660f79c614dbdc8b5d35d77f85511e42b5eb1cf5c8d6e
DIST aws-cli-1.33.42.gh.tar.gz 2770522 BLAKE2B 2a5a61ee0359a443c59330b5d5f939622e0ca36503ee4b3f343228f3aadff3741e43203b18b38c342fd838f1c624b6059746d56af9ba4065e8aeb570db1139d0 SHA512 bfdc55ab0d462d24769054bd5cad4af80da1ee6b4dd657a6f6a0c4543741cc93a36c7cef3176c3062e8ebbab6dc54d051e46ea09eb5bf39cf443ec0a18660441
DIST aws-cli-1.33.43.gh.tar.gz 2770673 BLAKE2B 4f43c3f6b5d71358caf2197be0b8cc114ba90a049fc99aa207e9fe26d33a6be7c9ee52ab8eecac442bb0b99139677b9005233549602d4a24a9f3e5e9a6ad1e3d SHA512 405d0999c38ff7f387ad583b21b8f54f0ea4334df5c10e4e830d17628c5071dbeda042dca9dc80766170caf5ad127a4051250e8a72d9ddfc96768b683d9c94c7
+DIST aws-cli-1.33.44.gh.tar.gz 2771513 BLAKE2B 38bf7bb84a6af998cd15ec8f0f331c19437fa6bcc65a32914188f0b9906c84738f9c0ea796849e513bc5183de5e96110f017f05a626a425d96d92cadc466c64c SHA512 c79f803f8abaec1ffc1575c863548e28f38bbb965c3d90ef5b92952dc22aa74c1f741545b414c33e65cd2dc514218987d71cbbe5567ae07c258dca6afc3e5944
diff --git a/app-admin/awscli/awscli-1.33.44.ebuild b/app-admin/awscli/awscli-1.33.44.ebuild
new file mode 100644
index 000000000000..c212ce9cac21
--- /dev/null
+++ b/app-admin/awscli/awscli-1.33.44.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).(z+118), sigh
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(( $(ver_cut 3-) + 118 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}