summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-10-01 11:24:06 -0400
committerKenton Groombridge <concord@gentoo.org>2023-10-01 11:25:44 -0400
commit660f8800a5e53b81328e1800e07df39bc16046a8 (patch)
treedf44a40e7e6e8e8e6ef86de752584d86ce8b937c /app-admin
parentapp-admin/mkosi: require >=systemd-245 (diff)
downloadgentoo-660f8800a5e53b81328e1800e07df39bc16046a8.tar.gz
gentoo-660f8800a5e53b81328e1800e07df39bc16046a8.tar.bz2
gentoo-660f8800a5e53b81328e1800e07df39bc16046a8.zip
app-admin/setools: drop 4.4.0-r3, 4.4.1, 4.4.1-r1
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/setools/Manifest2
-rw-r--r--app-admin/setools/files/0001-__init__.py-Make-NetworkX-dep-optional.patch62
-rw-r--r--app-admin/setools/files/setools-4.4.0-remove-gui.patch16
-rw-r--r--app-admin/setools/metadata.xml3
-rw-r--r--app-admin/setools/setools-4.4.0-r3.ebuild55
-rw-r--r--app-admin/setools/setools-4.4.1-r1.ebuild60
-rw-r--r--app-admin/setools/setools-4.4.1.ebuild56
7 files changed, 0 insertions, 254 deletions
diff --git a/app-admin/setools/Manifest b/app-admin/setools/Manifest
index 603bd4cea940..ebb92c6431fe 100644
--- a/app-admin/setools/Manifest
+++ b/app-admin/setools/Manifest
@@ -1,3 +1 @@
-DIST setools-4.4.0.tar.bz2 275218 BLAKE2B f716a78dd628e0309d3802f2155ef3a045dd8ebee7dec42be9f8b5fc0069b0df4e3d827b0a0cc03f7f02f5a3dff1d7ab7e4eee0d83d6cf4c87af82fe756a9321 SHA512 2ec92d7a6e30261549b6a8d2f17175d4a7d8313ef0cd81f4a19a91c53fe0107bac9a89c19dd67a4c534ee51ec520590795b4312f9e03e69fdf1763b0c35291f8
-DIST setools-4.4.1.tar.bz2 262328 BLAKE2B 328a54b8efd570fad03b27a9e52b7c573e0afb6fe23a245ad248fe8931dd737729aac5d9b6371c163d1939043a777b69cf78091cde8c33e5ef7670110615285e SHA512 af1844f7f7232729eb7e93f6680775818cda93532c62524c5385a4ac7437c51bdb58ebd970a9f61f6e1b018367853d35303d3c5ee1cc087e0e26e893be42d559
DIST setools-4.4.2.tar.bz2 261962 BLAKE2B 7c8e47d8c15f1eb72d93da5d3ae1a64e857ed0a75e1a47bbad9e4b0d11180581d9e4705ebe942e460acbc4d68261f06f9b03a8c4af1516cc388c201e30dca75e SHA512 4e8cba61ca28459387d862136a2d8ee0914c4bcd254a6d39792cbfcbbf7e58cb82223c05d66c114b08aebbd75c11cef11517c51f674ddb3c1913dc85414546c1
diff --git a/app-admin/setools/files/0001-__init__.py-Make-NetworkX-dep-optional.patch b/app-admin/setools/files/0001-__init__.py-Make-NetworkX-dep-optional.patch
deleted file mode 100644
index 3137f1a89f9a..000000000000
--- a/app-admin/setools/files/0001-__init__.py-Make-NetworkX-dep-optional.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 32eed2ae8fcd868179a317d48cfd61d828c834df Mon Sep 17 00:00:00 2001
-From: Jason Zaman <jason@perfinion.com>
-Date: Sun, 19 Sep 2021 14:12:44 +0200
-Subject: [PATCH] __init__.py: Make NetworkX dep optional
-
-selinux commit ba23ba068364ab11ff51f52bd1e20e3c63798a62
-"python: Import specific modules from setools for less deps"
-Makes userspace tools only need specific parts of setools so that the
-NetworkX dep can be dropped for minimal installations.
-Unfortunately the __init__ still imports the parts which require
-NetworkX. Wrap them in try except to guard for missing NetworkX.
-
-$ semanage export
-Traceback (most recent call last):
- File "/usr/lib/python-exec/python3.9/semanage", line 29, in <module>
- import seobject
- File "/usr/lib/python3.9/site-packages/seobject.py", line 33, in <module>
- import sepolicy
- File "/usr/lib/python3.9/site-packages/sepolicy/__init__.py", line 15, in <module>
- from setools.boolquery import BoolQuery
- File "/usr/lib/python3.9/site-packages/setools/__init__.py", line 94, in <module>
- from .infoflow import InfoFlowAnalysis
- File "/usr/lib/python3.9/site-packages/setools/infoflow.py", line 24, in <module>
- import networkx as nx
-ModuleNotFoundError: No module named 'networkx'
-
-Bug: https://bugs.gentoo.org/809038
-Signed-off-by: Jason Zaman <jason@perfinion.com>
----
- setools/__init__.py | 13 +++++++++++--
- 1 file changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/setools/__init__.py b/setools/__init__.py
-index d72d343..e583737 100644
---- a/setools/__init__.py
-+++ b/setools/__init__.py
-@@ -91,11 +91,20 @@ from .pcideviceconquery import PcideviceconQuery
- from .devicetreeconquery import DevicetreeconQuery
-
- # Information Flow Analysis
--from .infoflow import InfoFlowAnalysis
-+try:
-+ from .infoflow import InfoFlowAnalysis
-+except ImportError:
-+ # NetworkX is optional
-+ pass
-+
- from .permmap import PermissionMap, RuleWeight, Mapping
-
- # Domain Transition Analysis
--from .dta import DomainTransitionAnalysis, DomainEntrypoint, DomainTransition
-+try:
-+ from .dta import DomainTransitionAnalysis, DomainEntrypoint, DomainTransition
-+except ImportError:
-+ # NetworkX is optional
-+ pass
-
- # Policy difference
- from .diff import PolicyDifference
---
-2.32.0
-
diff --git a/app-admin/setools/files/setools-4.4.0-remove-gui.patch b/app-admin/setools/files/setools-4.4.0-remove-gui.patch
deleted file mode 100644
index 01b40adb29db..000000000000
--- a/app-admin/setools/files/setools-4.4.0-remove-gui.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/setup.py 2021-03-17 22:56:42.016632635 +0000
-+++ b/setup.py 2021-03-17 23:02:33.625713629 +0000
-@@ -139,10 +139,10 @@ setup(name='setools',
- author_email='pebenito@ieee.org',
- url='https://github.com/SELinuxProject/setools',
- cmdclass={'build_qhc': QtHelpCommand, 'clean': CleanCommand},
-- packages=['setools', 'setools.checker', 'setools.diff', 'setoolsgui', 'setoolsgui.apol'],
-- scripts=['apol', 'sediff', 'seinfo', 'seinfoflow', 'sesearch', 'sedta', 'sechecker'],
-+ packages=['setools', 'setools.checker', 'setools.diff'],
-+ scripts=['sediff', 'seinfo', 'seinfoflow', 'sesearch', 'sedta', 'sechecker'],
- data_files=installed_data,
-- package_data={'': ['*.ui', '*.qhc', '*.qch'], 'setools': ['perm_map']},
-+ package_data={'setools': ['perm_map']},
- ext_modules=cythonize(ext_py_mods, include_path=['setools/policyrep'],
- annotate=cython_annotate,
- compiler_directives={"language_level": 3,
diff --git a/app-admin/setools/metadata.xml b/app-admin/setools/metadata.xml
index 9e77647c601c..2367a4105f5c 100644
--- a/app-admin/setools/metadata.xml
+++ b/app-admin/setools/metadata.xml
@@ -5,9 +5,6 @@
<email>selinux@gentoo.org</email>
<name>SELinux Team</name>
</maintainer>
- <use>
- <flag name="infoflow">Depend on <pkg>dev-python/networkx</pkg> to use seinfoflow</flag>
- </use>
<upstream>
<remote-id type="github">SELinuxProject/setools</remote-id>
</upstream>
diff --git a/app-admin/setools/setools-4.4.0-r3.ebuild b/app-admin/setools/setools-4.4.0-r3.ebuild
deleted file mode 100644
index 7281dedc3904..000000000000
--- a/app-admin/setools/setools-4.4.0-r3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Policy Analysis Tools for SELinux"
-HOMEPAGE="https://github.com/SELinuxProject/setools/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/setools.git"
-else
- SRC_URI="https://github.com/SELinuxProject/setools/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS="amd64 arm arm64 x86"
-fi
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-IUSE="test infoflow X"
-RESTRICT="!test? ( test )"
-S="${WORKDIR}/${PN}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=sys-libs/libsepol-3.2:=
- >=sys-libs/libselinux-3.2:=
- infoflow? ( >=dev-python/networkx-2.0[${PYTHON_USEDEP}] )
- X? (
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
- )"
-DEPEND="${RDEPEND}"
-BDEPEND="<dev-python/cython-3[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/networkx-2.0[${PYTHON_USEDEP}]
- sys-apps/checkpolicy
- )"
-
-python_prepare_all() {
- sed -i "s/'-Werror', //" "${S}"/setup.py || die "failed to remove Werror"
- sed -i "s@^lib_dirs = .*@lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@" "${S}"/setup.py || \
- die "failed to set lib_dirs"
-
- local PATCHES=( "${FILESDIR}"/0001-__init__.py-Make-NetworkX-dep-optional.patch )
- use X || PATCHES+=( "${FILESDIR}"/setools-4.4.0-remove-gui.patch )
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/app-admin/setools/setools-4.4.1-r1.ebuild b/app-admin/setools/setools-4.4.1-r1.ebuild
deleted file mode 100644
index b47388f73018..000000000000
--- a/app-admin/setools/setools-4.4.1-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_EXT=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Policy Analysis Tools for SELinux"
-HOMEPAGE="https://github.com/SELinuxProject/setools/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/setools.git"
- S="${WORKDIR}/${P}"
-else
- SRC_URI="https://github.com/SELinuxProject/setools/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
- S="${WORKDIR}/${PN}"
-fi
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-IUSE="test infoflow X"
-RESTRICT="!test? ( test )"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=sys-libs/libsepol-3.2:=
- >=sys-libs/libselinux-3.2:=
- infoflow? ( >=dev-python/networkx-2.0[${PYTHON_USEDEP}] )
- X? (
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
- )"
-DEPEND="${RDEPEND}"
-BDEPEND=">=dev-python/cython-0.27[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/networkx-2.0[${PYTHON_USEDEP}]
- sys-apps/checkpolicy
- )"
-
-PATCHES=(
- "${FILESDIR}"/0001-__init__.py-Make-NetworkX-dep-optional.patch
- "${FILESDIR}"/${P}-cython3.patch
-)
-
-distutils_enable_tests setup.py
-
-python_prepare_all() {
- sed -i "s/'-Werror', //" "${S}"/setup.py || die "failed to remove Werror"
- sed -i "s@^lib_dirs = .*@lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@" "${S}"/setup.py || \
- die "failed to set lib_dirs"
-
- use X || PATCHES+=( "${FILESDIR}"/setools-4.4.0-remove-gui.patch )
- distutils-r1_python_prepare_all
-}
diff --git a/app-admin/setools/setools-4.4.1.ebuild b/app-admin/setools/setools-4.4.1.ebuild
deleted file mode 100644
index 52dcc404d73c..000000000000
--- a/app-admin/setools/setools-4.4.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Policy Analysis Tools for SELinux"
-HOMEPAGE="https://github.com/SELinuxProject/setools/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/setools.git"
- S="${WORKDIR}/${P}"
-else
- SRC_URI="https://github.com/SELinuxProject/setools/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
- S="${WORKDIR}/${PN}"
-fi
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-IUSE="test infoflow X"
-RESTRICT="!test? ( test )"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=sys-libs/libsepol-3.2:=
- >=sys-libs/libselinux-3.2:=
- infoflow? ( >=dev-python/networkx-2.0[${PYTHON_USEDEP}] )
- X? (
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
- )"
-DEPEND="${RDEPEND}"
-BDEPEND=">=dev-python/cython-0.27[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/networkx-2.0[${PYTHON_USEDEP}]
- sys-apps/checkpolicy
- )"
-
-python_prepare_all() {
- sed -i "s/'-Werror', //" "${S}"/setup.py || die "failed to remove Werror"
- sed -i "s@^lib_dirs = .*@lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@" "${S}"/setup.py || \
- die "failed to set lib_dirs"
-
- PATCHES=( "${FILESDIR}"/0001-__init__.py-Make-NetworkX-dep-optional.patch )
- use X || PATCHES+=( "${FILESDIR}"/setools-4.4.0-remove-gui.patch )
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}