summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-06-04 20:07:29 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-06-04 20:13:42 +0300
commit54f05830c5930eb3940b4808db266369c65f3e29 (patch)
treea883d2ae3f89c0158027a21e76722cb6c717bbeb /app-admin
parentdev-java/httpcomponents-client: add verify-sig, update EAPI 7 -> 8 (diff)
downloadgentoo-54f05830c5930eb3940b4808db266369c65f3e29.tar.gz
gentoo-54f05830c5930eb3940b4808db266369c65f3e29.tar.bz2
gentoo-54f05830c5930eb3940b4808db266369c65f3e29.zip
app-admin/linode-cli: add 5.50.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/linode-cli/Manifest1
-rw-r--r--app-admin/linode-cli/linode-cli-5.50.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/linode-cli/Manifest b/app-admin/linode-cli/Manifest
index 6d4f5deb8e8f..7647eaa761b0 100644
--- a/app-admin/linode-cli/Manifest
+++ b/app-admin/linode-cli/Manifest
@@ -1,2 +1,3 @@
DIST linode_cli-5.48.4.tar.gz 142928 BLAKE2B 28b1c90bb0709afc594b7023ef846b6d59e0376730f05d9701ebbc6744376f33536ad5a6f53b7b26a25805b258dc58378a76b0e6a4157e149f83e691d862dec8 SHA512 b07a3612afc329fc346b523412ac03932c84213d6bc23726f4c0e5edc737100bf65ec84f8131943439444fee268646789dc4d135cd61b2362311d1ab18601c3e
DIST linode_cli-5.49.1.tar.gz 146883 BLAKE2B b4124b84f812b00c93e09e7c91c128b7ff15fbaf3a5c487613dbc4d26b1c5f00f083f521d8501e9a8649d3dc970a6349100602586dbb4acec27a7859470ba3b1 SHA512 06859939ac0c65a152acc012c87c53322a2a8cc1d4267c5dd0526b8ed0ad2b7aad7f3df42e24657d9bcca4b3fa02956ec23ea0d90ce4f5f9b61247a5b288dc72
+DIST linode_cli-5.50.0.tar.gz 146902 BLAKE2B ebe83454f06bc281a91dcc276db7378779d73717ca49bbcc81fe59e61c6eb448d7a7bde9e5482bb21ca05c0484001f86dab4b4296011ecbb156c13b38573f7ea SHA512 3fb95f76c19f17f897ebce3bfb6d32de1f9a2ed2d8ba9078180e465acbe20b873a59092809a2c766c326e0c5e27c983c84aef9ae7c210004f51b2b62225694e1
diff --git a/app-admin/linode-cli/linode-cli-5.50.0.ebuild b/app-admin/linode-cli/linode-cli-5.50.0.ebuild
new file mode 100644
index 000000000000..21d1ca44d811
--- /dev/null
+++ b/app-admin/linode-cli/linode-cli-5.50.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi shell-completion
+
+DESCRIPTION="Official command-line interface for interacting with the Linode API"
+HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests require network, a linode account and an API key.
+# WARNING: tests will incur costs and will wipe the account.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ >=dev-python/linode-metadata-0.3[${PYTHON_USEDEP}]
+ dev-python/openapi3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ PYTHONPATH=. ${EPYTHON} linodecli completion bash > "${T}/${PN}".bash || die
+ PYTHONPATH=. ${EPYTHON} linodecli completion fish > "${T}/${PN}".fish || die
+
+ newbashcomp "${T}/${PN}".bash ${PN}
+ newfishcomp "${T}/${PN}".fish ${PN}
+
+ dosym ${PN} "$(get_bashcompdir)"/linode
+ dosym ${PN} "$(get_bashcompdir)"/lin
+ dosym ${PN} "$(get_fishcompdir)"/linode
+ dosym ${PN} "$(get_fishcompdir)"/lin
+}