summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-08 04:11:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-08 05:07:49 +0200
commit51fd7cf398a29ff1232ef68202cc9c9e01ef5d15 (patch)
tree140e5f42c600f0d177f569008770d2ff633f249f /app-admin
parentdev-python/trimesh: Bump to 4.4.4 (diff)
downloadgentoo-51fd7cf398a29ff1232ef68202cc9c9e01ef5d15.tar.gz
gentoo-51fd7cf398a29ff1232ef68202cc9c9e01ef5d15.tar.bz2
gentoo-51fd7cf398a29ff1232ef68202cc9c9e01ef5d15.zip
app-admin/awscli: Bump to 1.33.38
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.33.38.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 47694434a7df..83216fe2b426 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.33.31.gh.tar.gz 2765982 BLAKE2B 424422520aada1a5ab21843e61d502793
DIST aws-cli-1.33.35.gh.tar.gz 2768498 BLAKE2B d925c1a63a73bda27711d2f930d0832ea17e012d62d634330cef16f1962cbcbeb9149a5ef14765af04bfbc4b49c6160a319e02a3eab475473a2fe46ab27da305 SHA512 5804947acc002cd9f53b94865542d4f4708116a3a31dafd6a217e84d2222ff973b6c6af0237272d52d9d15e0eaf7f243ef577c1a1b3c2f18e845857886d9f2c1
DIST aws-cli-1.33.36.gh.tar.gz 2768813 BLAKE2B dbeaf0049d855da5b20c6ce24201dca4347ce72ca9546b1a6479d864f650fb39b0e557cf1f3a35a3165c118700fd0e06417c2ae594053992a8d16c3a95376e43 SHA512 6de8542a11bfa6e076bb7d99f6573d04b16bcae65c07a33b518d5dc3ea20dacf899f6929c8892731c98e77381ce5986d82e508b2f2c72854d3cd4c647979d41a
DIST aws-cli-1.33.37.gh.tar.gz 2769229 BLAKE2B 39ef0d26e555f197cb4b4b588dc1fc9cad1562ba15926e349cae6e409bced94443403c6975ce08c69431accc45557e5659c6a23b686c7d046a7a338b4968a6a1 SHA512 d50150e04695ac651d27c7bdd23e79b5031f9e54fe2f00e6c1b78b5d2a22afac34a242e6473de52c813d85c219274fca472abb9dc70318c203a7638d2f869e42
+DIST aws-cli-1.33.38.gh.tar.gz 2769355 BLAKE2B fd943a5d41a2426ad022156f48f972915d019e0e20ab9b64d498426402c0fa5d1ab45ffd1927fcc5a49d62266c3b02a81c3875f396e3fc919fcaae1e9b8d5f1e SHA512 27759a759eabe66d2b3058e1c8acb747debf34f5b737f5096937886771d754f3a926a7da82d4fc4e68cd118338a86945f6f4ecc3d23f297af32f12aa1a8f1323
diff --git a/app-admin/awscli/awscli-1.33.38.ebuild b/app-admin/awscli/awscli-1.33.38.ebuild
new file mode 100644
index 000000000000..c212ce9cac21
--- /dev/null
+++ b/app-admin/awscli/awscli-1.33.38.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).(z+118), sigh
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(( $(ver_cut 3-) + 118 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}