summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-08-22 00:15:36 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-08-22 00:17:16 -0500
commit173211aebe2794d734bdd60d710a4c2b657ce3bf (patch)
tree927f29793db63e608dc7d6d78637d67b9edd7896 /app-admin
parentdev-libs/tinyxml2: arm stable, bug #661440 (diff)
downloadgentoo-173211aebe2794d734bdd60d710a4c2b657ce3bf.tar.gz
gentoo-173211aebe2794d734bdd60d710a4c2b657ce3bf.tar.bz2
gentoo-173211aebe2794d734bdd60d710a4c2b657ce3bf.zip
app-admin/mcollective: 2.12.3 bump
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mcollective/Manifest1
-rw-r--r--app-admin/mcollective/mcollective-2.12.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/mcollective/Manifest b/app-admin/mcollective/Manifest
index c25fd65bad62..576d8d8a6ea0 100644
--- a/app-admin/mcollective/Manifest
+++ b/app-admin/mcollective/Manifest
@@ -1,2 +1,3 @@
DIST mcollective-2.12.1.tar.gz 1517946 BLAKE2B 785acc53a4854f47caebe1d6a5f9cc850c3c33fd21e1b6e57d0d9761b2a7a3bbab2f2df398aa5344d90bc11397a545c8663d60ff3b2f6ff835fdc619d874928e SHA512 2398fb0202d8d5669a6efa81d96a87ee7e9221c1bc1b2e5be1917f2fec2527879b34be8df8c3052acf0ed58074b2da185f0837889d9300bde190bc95e8237d9a
DIST mcollective-2.12.2.tar.gz 1517725 BLAKE2B e5f2b94843b95fa0749ed7e3e1ae52aeb485bf6644b64d971efd7d7a0e7bc806de0d2b00997c7e36d004fd78c479b9cf19b927e717ad0f3e4c13e820e5481637 SHA512 83be835499adf836797a67adda9be6d1bbf32524560ae51533875a1e2507599c7a0a1d2a76513669b919cf1eeceabdf13162eedb8972c74ecdeba5427b1701e4
+DIST mcollective-2.12.3.tar.gz 1516461 BLAKE2B f8fa65ffadb98ae3511416aaf8b0875486b75f20e4da4007ad70820f453a6ecd81b57d7aa30ae38b014b984330f6c4d525002a54edb2c00d629b6fd4b2250049 SHA512 55798d4579a6be8a7790b046f8b4e72607935c83ec874b6147258d827e0bf279f08dfa121d7cc4a8ed922986aa6bad9ebd62b7e3cbc1e7ef526cf58edce1bcdc
diff --git a/app-admin/mcollective/mcollective-2.12.3.ebuild b/app-admin/mcollective/mcollective-2.12.3.ebuild
new file mode 100644
index 000000000000..6682ac763bea
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.12.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="https://docs.puppet.com/mcollective/"
+SRC_URI="https://github.com/puppetlabs/marionette-collective/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/all/marionette-collective-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND=">=dev-ruby/stomp-1.4.4"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ cd "marionette-collective-${PV}"
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ use client && dosbin bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] https://activemq.apache.org/"
+ einfo "[2] https://code.google.com/p/mcollective/wiki/GettingStarted"
+}