summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-11-27 07:16:47 -0600
committerBen Kohler <bkohler@gentoo.org>2023-11-27 07:35:24 -0600
commit7ee102da17823ef31f0e45753b39efae0c6d527c (patch)
treec680e40f334e1468e83e77c9ecbee30ec00c2e3c /app-admin/xkcdpass
parentdev-python/conway-polynomials: add 0.8, drop 0.7 (diff)
downloadgentoo-7ee102da17823ef31f0e45753b39efae0c6d527c.tar.gz
gentoo-7ee102da17823ef31f0e45753b39efae0c6d527c.tar.bz2
gentoo-7ee102da17823ef31f0e45753b39efae0c6d527c.zip
app-admin/xkcdpass: add 1.19.6
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-admin/xkcdpass')
-rw-r--r--app-admin/xkcdpass/Manifest1
-rw-r--r--app-admin/xkcdpass/xkcdpass-1.19.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/xkcdpass/Manifest b/app-admin/xkcdpass/Manifest
index a5ede4e25efe..9fb5ae9bacbe 100644
--- a/app-admin/xkcdpass/Manifest
+++ b/app-admin/xkcdpass/Manifest
@@ -1,2 +1,3 @@
DIST xkcdpass-1.19.4.tar.gz 2572291 BLAKE2B f36299ab66bc02f95a7811ebdf40fa62f441a0ef1eac27af8d380fca9643eb9c2444c988392900e5add8a2a22f4ef33766bc5904fb350520b0b7572e95898ecd SHA512 2a83473f6e2426f34ee89297056ca7d3949044f7e818f6d6501fd7852ac1ba9f860f8287ad6d366f13f46f580b0f3f7e9a3dfa160b262b4d00b00ed1c9f5da59
DIST xkcdpass-1.19.5.tar.gz 2572430 BLAKE2B e955780492d2771558bc1f0716913f4e84a408d98049b2f5f23d53a56e6d660bc1afb2539b3f422bdc98df05ae065c51f0303ddaf2e268994420a22580aba2a2 SHA512 8a560247cb860377ef723b26610a6f784a891b4c8dfb2c5b55187df70e326d6ff2f1d31128dfc4e7136cbc15108c470658d896056177900e0eb419d14458348f
+DIST xkcdpass-1.19.6.tar.gz 2572473 BLAKE2B 638aaa482f5d468e89daef7cb59dcba183b11280356a9e3a6aa518a0e8c0b9931057c1ffc6ebf3fd45111389a3f2952c4a668421f1b4822e64cbe0f1ade8d702 SHA512 ca61424432ab3749ee5a3fca884ed0897e5f342a84bfe208e4ae1dde3db60218f99f60d62cb77c05ccf8fd81ae393779869236aa2ee7cd7ebd3cf89663d47c13
diff --git a/app-admin/xkcdpass/xkcdpass-1.19.6.ebuild b/app-admin/xkcdpass/xkcdpass-1.19.6.ebuild
new file mode 100644
index 000000000000..767282c1f31d
--- /dev/null
+++ b/app-admin/xkcdpass/xkcdpass-1.19.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Password generator inspired by XKCD 936"
+HOMEPAGE="https://github.com/redacted/XKCD-password-generator"
+
+LICENSE="BSD CC-BY-3.0
+ l10n_de? ( GPL-3 )
+ l10n_it? ( CC-BY-SA-3.0 )
+ l10n_no? ( CC-BY-4.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="l10n_de +l10n_en l10n_es l10n_fi l10n_fr l10n_it l10n_no l10n_pt"
+
+distutils_enable_tests pytest
+REQUIRED_USE="test? ( l10n_en )"
+
+PATCHES=( "${FILESDIR}"/xkcdpass-1.19.4-no-examples-in-site-packages.patch )
+
+src_prepare() {
+ default
+
+ use l10n_de || rm ${PN}/static/{ger-anlx,eff_large_de_sample.wordlist}
+ use l10n_en || rm ${PN}/static/{eff-short,eff-special,legacy}
+ use l10n_es || rm ${PN}/static/spa-mich
+ use l10n_fi || rm ${PN}/static/fin-kotus
+ use l10n_fr || rm ${PN}/static/fr-*
+ use l10n_it || rm ${PN}/static/ita-wiki
+ use l10n_no || rm ${PN}/static/nor-nb
+ use l10n_pt || rm ${PN}/static/pt-*
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}