summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-15 12:46:39 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-15 13:32:09 +0100
commite223cf2f5eeb23b476eaf2e3862b52986e8e797a (patch)
treeef38ddac7afadf7383e548e632cf8a95bbe6a8a1 /app-admin/lastpass-cli
parentdev-python/paramiko: Drop old (diff)
downloadgentoo-e223cf2f5eeb23b476eaf2e3862b52986e8e797a.tar.gz
gentoo-e223cf2f5eeb23b476eaf2e3862b52986e8e797a.tar.bz2
gentoo-e223cf2f5eeb23b476eaf2e3862b52986e8e797a.zip
app-admin/lastpass-cli: Respect CC
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-admin/lastpass-cli')
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-0.8.0-r1.ebuild (renamed from app-admin/lastpass-cli/lastpass-cli-0.8.0.ebuild)8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-admin/lastpass-cli/lastpass-cli-0.8.0.ebuild b/app-admin/lastpass-cli/lastpass-cli-0.8.0-r1.ebuild
index 242be9964390..8bb6a25f0af2 100644
--- a/app-admin/lastpass-cli/lastpass-cli-0.8.0.ebuild
+++ b/app-admin/lastpass-cli/lastpass-cli-0.8.0-r1.ebuild
@@ -4,9 +4,11 @@
EAPI=5
+inherit toolchain-funcs
+
DESCRIPTION="Interfaces with LastPass.com from the command line."
-SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
@@ -23,6 +25,10 @@ RDEPEND="
"
DEPEND="${RDEPEND} app-text/asciidoc"
+src_prepare() {
+ tc-export CC
+}
+
src_compile() {
emake PREFIX="${EPREFIX}/usr"
emake PREFIX="${EPREFIX}/usr" doc-man