summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-24 10:00:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-24 10:00:36 +0100
commit8ef1efb3e6f9dea9e31db2cb8f479a28d7acfb39 (patch)
tree40c7697563c3392ef26be8e04be9200adde50d91 /app-admin/awscli/awscli-1.22.80.ebuild
parentdev-python/boto3: Bump to 1.21.25 (diff)
downloadgentoo-8ef1efb3e6f9dea9e31db2cb8f479a28d7acfb39.tar.gz
gentoo-8ef1efb3e6f9dea9e31db2cb8f479a28d7acfb39.tar.bz2
gentoo-8ef1efb3e6f9dea9e31db2cb8f479a28d7acfb39.zip
app-admin/awscli: Bump to 1.22.80
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli/awscli-1.22.80.ebuild')
-rw-r--r--app-admin/awscli/awscli-1.22.80.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/awscli/awscli-1.22.80.ebuild b/app-admin/awscli/awscli-1.22.80.ebuild
new file mode 100644
index 000000000000..2040c8cb81d2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.80.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}