summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-23 19:57:32 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-23 19:58:40 -0400
commitcf64ce7d2596423e2878fcf1e8365ddb158b072b (patch)
tree7a8b03f58a4db1d4b2bb18ccc4c591cd044de2f1
parentx11-apps/xdm: Version bump to 1.1.15 (diff)
downloadgentoo-cf64ce7d2596423e2878fcf1e8365ddb158b072b.tar.gz
gentoo-cf64ce7d2596423e2878fcf1e8365ddb158b072b.tar.bz2
gentoo-cf64ce7d2596423e2878fcf1e8365ddb158b072b.zip
x11-libs/libpciaccess: Version bump to 0.18.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libpciaccess/Manifest1
-rw-r--r--x11-libs/libpciaccess/libpciaccess-0.18.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/x11-libs/libpciaccess/Manifest b/x11-libs/libpciaccess/Manifest
index 93cf7ce466b5..47e634a93244 100644
--- a/x11-libs/libpciaccess/Manifest
+++ b/x11-libs/libpciaccess/Manifest
@@ -1 +1,2 @@
+DIST libpciaccess-0.18.1.tar.xz 64452 BLAKE2B 19ebe4e8cb3f409f51be01d0c771aea79d9251d7b464f49d8adf40af55180b0f87c6092271023289f802cc2b684eecace963b5fdcb026ff7879481d22a34a675 SHA512 ef27999446e735df2331e94219ee3dafe9198a2472bb452f63ef9c9c446d5431f9e231e224cfabdeba1402974a5a0064546f9abced4d1770f994f5fc0c2b3310
DIST libpciaccess-0.18.tar.xz 64452 BLAKE2B 06309f98aee985c92c2389344fdd0fcb4bebc6c69d71198e6bf5bc165dce85c7fd54aa1ff9454ee430264a8e1ff283976508285523d48d9948e242c53157761f SHA512 54dff9a493344586d072edf8c8eb8f7960c7dfd64aa5c51a8ec8d4e341f703fd39eb606ee41c4fdd9d5aad3372b7efe6e0fe96eadc575ea91de276320ebc3fbd
diff --git a/x11-libs/libpciaccess/libpciaccess-0.18.1.ebuild b/x11-libs/libpciaccess/libpciaccess-0.18.1.ebuild
new file mode 100644
index 000000000000..fdc380f05cd5
--- /dev/null
+++ b/x11-libs/libpciaccess/libpciaccess-0.18.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3 meson-multilib
+
+DESCRIPTION="Library providing generic access to the PCI bus and devices"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="zlib"
+
+DEPEND="
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+ sys-apps/hwdata"
+
+src_prepare() {
+ default
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dpci-ids="${EPREFIX}"/usr/share/hwdata
+ $(meson_feature zlib)
+ )
+ meson_src_configure
+}