summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-15 11:40:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-15 12:51:05 +0200
commitcf130e89b60e68e94bd555f063ee8c2353ada25f (patch)
tree4c6caf74f56c6be0eb9cf8815954ebe7bcb83e5a
parentgames-emulation/mupen64plus-input-sdl: Bump to 2.6.0 (diff)
downloadgentoo-cf130e89b60e68e94bd555f063ee8c2353ada25f.tar.gz
gentoo-cf130e89b60e68e94bd555f063ee8c2353ada25f.tar.bz2
gentoo-cf130e89b60e68e94bd555f063ee8c2353ada25f.zip
games-emulation/mupen64plus-rsp-hle: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-emulation/mupen64plus-rsp-hle/Manifest1
-rw-r--r--games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.6.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-rsp-hle/Manifest b/games-emulation/mupen64plus-rsp-hle/Manifest
index b2feef8e2ff9..d51d879f2cc1 100644
--- a/games-emulation/mupen64plus-rsp-hle/Manifest
+++ b/games-emulation/mupen64plus-rsp-hle/Manifest
@@ -1 +1,2 @@
DIST mupen64plus-rsp-hle-src-2.5.9.tar.gz 53889 BLAKE2B e66996ffbce1d4b2b40f1520f0806692652dbf7baa55a73f632f2dafe75f93093e0575bb1c7e63cc1cd8770c1cc0e6d59db9021fcb0fa2e34d707511dd3a40b0 SHA512 562f3a9d9eff01f11c13aca657fb6471f365fbfbe079ea5e1e6f0ad49b27ba04779bc86233bcacd20c95c79f7fa265f053b3fa4c2b12828c6a8992762c4b6963
+DIST mupen64plus-rsp-hle-src-2.6.0.tar.gz 60324 BLAKE2B 134a597b8f69b6a9adc3048f4f4ca6fc2be779b5bc3fc3a09006e3f28ca1d14a7c58429cdad6ed37493f1ff1b2b2afaa8bf4839cfd514812a4088fe78472ff59 SHA512 d238f3fb8f8e1835828c01d8305167444969e5d58ccad94908aadcdb75039dddbaef9a2bbaaf83396f747e4d60c368bc8e03128f68ce8790127bf5fc0c19c07f
diff --git a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.6.0.ebuild b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.6.0.ebuild
new file mode 100644
index 000000000000..617af625e124
--- /dev/null
+++ b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.6.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P=${PN}-src-${PV}
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, HLE RSP plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="
+ https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=games-emulation/mupen64plus-core-${PV}:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ dodoc RELEASE
+}