summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenoît Gschwind <gschwind@gnu-log.net>2023-03-05 11:09:12 +0100
committerMatt Turner <mattst88@gentoo.org>2023-03-05 12:04:32 -0500
commitbb190d14b8272f731083fd03b65a13f8abef6123 (patch)
tree071274beb84faf935cfa5e86b84bf897d665bc9f
parentdev-libs/girara: Stabilize 0.3.9 arm, #899670 (diff)
downloadgentoo-bb190d14b8272f731083fd03b65a13f8abef6123.tar.gz
gentoo-bb190d14b8272f731083fd03b65a13f8abef6123.tar.bz2
gentoo-bb190d14b8272f731083fd03b65a13f8abef6123.zip
x11-wm/page: Drop outdated use-dependencies
Closes : https://bugs.gentoo.org/876004 Signed-off-by: Benoît Gschwind <gschwind@gnu-log.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-wm/page/page-1.9.10-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-wm/page/page-1.9.10-r1.ebuild b/x11-wm/page/page-1.9.10-r1.ebuild
new file mode 100644
index 000000000000..9dcfac0380fd
--- /dev/null
+++ b/x11-wm/page/page-1.9.10-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A mouse friendly tiling window manager"
+HOMEPAGE="https://github.com/gschwind/page"
+SRC_URI="https://github.com/gschwind/page/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11
+ >=x11-libs/xcb-util-0.4.0
+ >=x11-libs/libXfixes-5.0.3
+ >=x11-libs/libXdamage-1.1.4-r1
+ >=x11-libs/libXrandr-1.5.1
+ >=x11-libs/libXcomposite-0.4.4-r1
+ >=x11-libs/libXrender-0.9.10
+ >=x11-libs/libXext-1.3.3
+ >=x11-libs/cairo-1.14.6[X]
+ >=x11-libs/pango-1.40.5
+ >=dev-libs/glib-2.50.3-r1:2"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.12-r2
+ x11-base/xorg-proto"
+
+src_install() {
+ default
+
+ # Solves file collision with dev-tcltk/tcllib, bug #574074
+ ebegin "Changing references from 'page' to 'pagewm'"
+ mv "${ED}"/usr/bin/page "${ED}"/usr/bin/pagewm || die "Could not rename binary!"
+ sed -i -e "s:/usr/bin/page:/usr/bin/pagewm:" "${ED}"/usr/share/applications/page.desktop || die "Could not change .desktop file!"
+ eend $?
+}
+
+pkg_postinst() {
+ elog "page can now be launched using \"pagewm\". To find out more about this functionality,"
+ elog "see the following bug report: https://bugs.gentoo.org/574074."
+}