summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-11 20:30:59 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-11 21:43:34 +0300
commitb184399e57e7e8f9bde2c303d7178f17ec9f49de (patch)
tree048e956fc130cefe1523e3ac76bbb64f67873f3d
parentdev-php/PEAR-Image_Color2: treeclean (diff)
downloadgentoo-b184399e57e7e8f9bde2c303d7178f17ec9f49de.tar.gz
gentoo-b184399e57e7e8f9bde2c303d7178f17ec9f49de.tar.bz2
gentoo-b184399e57e7e8f9bde2c303d7178f17ec9f49de.zip
dev-php/PEAR-Image_GraphViz: treeclean
Bug: https://bugs.gentoo.org/933998 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--dev-php/PEAR-Image_GraphViz/Manifest1
-rw-r--r--dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild27
-rw-r--r--dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch55
-rw-r--r--dev-php/PEAR-Image_GraphViz/metadata.xml8
4 files changed, 0 insertions, 91 deletions
diff --git a/dev-php/PEAR-Image_GraphViz/Manifest b/dev-php/PEAR-Image_GraphViz/Manifest
deleted file mode 100644
index 4097cd462119..000000000000
--- a/dev-php/PEAR-Image_GraphViz/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Image_GraphViz-1.3.0_p20151104.tar.gz 18109 BLAKE2B 9a8c269a7f4eff787a67c84770c296d3e032a038cae04b888ea5ae26525b24a764ad01d6300d7e7a4c3cf78acb4e077b1f9091cced4ef57031f6ce3aaef2a8e3 SHA512 69e9117cff950a45d8f3cfd5759be8194f477b55c09ceb990707f3ad2de2500a570fa124b73b2c81cdd6ce20b6c11fc0532a0087a515cf3c7c9a5a8ed7b1c58f
diff --git a/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild b/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
deleted file mode 100644
index a7c53943be47..000000000000
--- a/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit php-pear-r2 vcs-snapshot
-
-DESCRIPTION="PHP interface to AT&T's GraphViz tools"
-SRC_URI="https://github.com/pear/Image_GraphViz/archive/3f8a01ae0597ca9d1d08a6e442cb0b153358fc0d.tar.gz -> ${PEAR_P}.tar.gz"
-LICENSE="PHP-3"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="media-gfx/graphviz"
-DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
-PATCHES=( "${FILESDIR}/Image_GraphViz-1.3.0-constructor.patch" )
-S="${WORKDIR}/${PEAR_P}"
-
-src_prepare() {
- mv "${S}/package.xml" "${WORKDIR}" || die
- default
-}
-
-src_test() {
- peardev run-tests tests || die
-}
diff --git a/dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch b/dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch
deleted file mode 100644
index da7dfd4724ca..000000000000
--- a/dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 794fdf40ad944225854845a0ff32a5c56fb249d9 Mon Sep 17 00:00:00 2001
-From: Seb35 <seb35@seb35.fr>
-Date: Sun, 6 Nov 2016 22:42:46 +0100
-Subject: [PATCH] Added __construct constructor
-
-This removes deprecation warnings due to old constructor
-(method with the class name). Keep the old-style constructor
-for compatibility (like in the PEAR main class).
----
- Image/GraphViz.php | 25 ++++++++++++++++++++++++-
- 1 file changed, 24 insertions(+), 1 deletion(-)
-
-diff --git a/Image/GraphViz.php b/Image/GraphViz.php
-index ee84ff2..92842da 100644
---- a/Image/GraphViz.php
-+++ b/Image/GraphViz.php
-@@ -181,7 +181,7 @@ class Image_GraphViz
- *
- * @access public
- */
-- function Image_GraphViz($directed = true, $attributes = array(),
-+ function __construct($directed = true, $attributes = array(),
- $name = 'G', $strict = true, $returnError = false)
- {
- $this->setDirected($directed);
-@@ -192,6 +192,29 @@ function Image_GraphViz($directed = true, $attributes = array(),
- $this->_returnFalseOnError = !$returnError;
- }
-
-+ /**
-+ * Compatibility constructor.
-+ *
-+ * @param boolean $directed Directed (TRUE) or undirected (FALSE) graph.
-+ * Note: You MUST pass a boolean, and not just
-+ * an expression that evaluates to TRUE or
-+ * FALSE (i.e. NULL, empty string, 0 will NOT
-+ * work)
-+ * @param array $attributes Attributes of the graph
-+ * @param string $name Name of the Graph
-+ * @param boolean $strict Whether to collapse multiple edges between
-+ * same nodes
-+ * @param boolean $returnError Set to TRUE to return PEAR_Error instances
-+ * on failures instead of FALSE
-+ *
-+ * @access public
-+ */
-+ function Image_GraphViz($directed = true, $attributes = array(),
-+ $name = 'G', $strict = true, $returnError = false)
-+ {
-+ self::__construct($directed, $attributes, $name, $strinct, $returnError);
-+ }
-+
- /**
- * Outputs image of the graph in a given format
- *
diff --git a/dev-php/PEAR-Image_GraphViz/metadata.xml b/dev-php/PEAR-Image_GraphViz/metadata.xml
deleted file mode 100644
index 222c77f3742a..000000000000
--- a/dev-php/PEAR-Image_GraphViz/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
-</pkgmetadata>