summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-03 19:37:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-03 19:38:02 +0200
commit992f85123e472e80aad4465585056b78b0c481fe (patch)
treea83af4e7772c16836abe293d1f86ae06c1fc219c
parentdev-libs/libixion: drop 0.17.0 (diff)
downloadgentoo-992f85123e472e80aad4465585056b78b0c481fe.tar.gz
gentoo-992f85123e472e80aad4465585056b78b0c481fe.tar.bz2
gentoo-992f85123e472e80aad4465585056b78b0c481fe.zip
dev-libs/liborcus: drop 0.17.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/liborcus/liborcus-0.17.2.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/dev-libs/liborcus/liborcus-0.17.2.ebuild b/dev-libs/liborcus/liborcus-0.17.2.ebuild
deleted file mode 100644
index 6250ac5bfc4c..000000000000
--- a/dev-libs/liborcus/liborcus-0.17.2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9,10} )
-
-inherit autotools python-single-r1
-
-DESCRIPTION="Standalone file import filter library for spreadsheet documents"
-HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
-
-if [[ ${PV} == *9999* ]]; then
- MDDS_SLOT="1/2.0"
- EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
- inherit git-r3
-else
- MDDS_SLOT="1/2.0"
- SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ~ppc64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/0.17" # based on SONAME of liborcus.so
-IUSE="python +spreadsheet-model test tools"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/boost:=[zlib(+)]
- sys-libs/zlib
- python? ( ${PYTHON_DEPS} )
- spreadsheet-model? ( dev-libs/libixion:${SLOT} )
-"
-DEPEND="${RDEPEND}
- dev-util/mdds:${MDDS_SLOT}
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-clang.patch
- "${FILESDIR}"/${P}-gcc-13.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # bug 713586
- use test && eapply "${FILESDIR}/${PN}-0.17.0-test-fix.patch"
-
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-static
- --disable-werror
- $(use_enable python)
- $(use_enable spreadsheet-model)
- $(use_with tools)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -type f -delete || die
-}