summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 10:33:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 11:57:04 +0100
commit975622857980795b95e505239c908937b8bb2c99 (patch)
tree9a7520f310f5444f770f55bdf7c840814a9ccc21
parentapp-editors/neovim: update tree-sitter dependencies to newest versions (diff)
downloadgentoo-975622857980795b95e505239c908937b8bb2c99.tar.gz
gentoo-975622857980795b95e505239c908937b8bb2c99.tar.bz2
gentoo-975622857980795b95e505239c908937b8bb2c99.zip
games-engines/scummvm: src_configure() cleanup
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-engines/scummvm/scummvm-2.9.0.ebuild5
-rw-r--r--games-engines/scummvm/scummvm-9999.ebuild7
2 files changed, 7 insertions, 5 deletions
diff --git a/games-engines/scummvm/scummvm-2.9.0.ebuild b/games-engines/scummvm/scummvm-2.9.0.ebuild
index 062895592e49..028e309ed016 100644
--- a/games-engines/scummvm/scummvm-2.9.0.ebuild
+++ b/games-engines/scummvm/scummvm-2.9.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
inherit desktop flag-o-matic toolchain-funcs xdg
DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
@@ -103,7 +104,7 @@ src_configure() {
$(use_enable debug)
$(use_enable !debug release-mode)
$(use_enable flac)
- $(usex fluidsynth '' --disable-fluidsynth)
+ $(use_enable fluidsynth)
$(use_enable fribidi)
$(use_enable gif)
$(use_enable gtk)
@@ -125,7 +126,7 @@ src_configure() {
)
echo "configure ${myconf[@]}"
# not an autoconf script, so don't call econf
- SDL_CONFIG="sdl2-config" \
+ local -x SDL_CONFIG="sdl2-config"
./configure "${myconf[@]}" ${EXTRA_ECONF} || die
}
diff --git a/games-engines/scummvm/scummvm-9999.ebuild b/games-engines/scummvm/scummvm-9999.ebuild
index 826f0cc2b782..028e309ed016 100644
--- a/games-engines/scummvm/scummvm-9999.ebuild
+++ b/games-engines/scummvm/scummvm-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
inherit desktop flag-o-matic toolchain-funcs xdg
DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
@@ -103,7 +104,7 @@ src_configure() {
$(use_enable debug)
$(use_enable !debug release-mode)
$(use_enable flac)
- $(usex fluidsynth '' --disable-fluidsynth)
+ $(use_enable fluidsynth)
$(use_enable fribidi)
$(use_enable gif)
$(use_enable gtk)
@@ -125,7 +126,7 @@ src_configure() {
)
echo "configure ${myconf[@]}"
# not an autoconf script, so don't call econf
- SDL_CONFIG="sdl2-config" \
+ local -x SDL_CONFIG="sdl2-config"
./configure "${myconf[@]}" ${EXTRA_ECONF} || die
}