summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-07-15 12:06:20 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-07-15 12:06:20 +0200
commit8e5c76fcd11b362f597326901feca6dcde6daca9 (patch)
treebc019255effe79d5da31af897e99984b8180a3f7
parentdev-ml/opam-core: drop 2.1.4 (diff)
downloadgentoo-8e5c76fcd11b362f597326901feca6dcde6daca9.tar.gz
gentoo-8e5c76fcd11b362f597326901feca6dcde6daca9.tar.bz2
gentoo-8e5c76fcd11b362f597326901feca6dcde6daca9.zip
dev-ml/opam-installer: add 2.1.5
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/opam-installer/Manifest1
-rw-r--r--dev-ml/opam-installer/opam-installer-2.1.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
index 4f87075e8b29..a004a07b0e44 100644
--- a/dev-ml/opam-installer/Manifest
+++ b/dev-ml/opam-installer/Manifest
@@ -3,3 +3,4 @@ DIST opam-full-2.0.10.tar.gz 8173617 BLAKE2B 6bf7a52835512b3de5bcf0de24f5ba3a322
DIST opam-full-2.0.9.tar.gz 8029605 BLAKE2B c2ae06bdbbdbe9db270ec0027ec8d13a228f0af2ae5089476fa3a698d27e1f47abf2e3a15ecc9ca610717ba6b979b4ca76cce56c52f6592ae789b88fb5e5b68d SHA512 9f44d878a2599a876f5e5b9b7457b6f446a5e59156ed3d449dcc29e40c44df8b69da619eabdf030e45526fba4bd9a00c65dec2c36552d2e03788596b0aceee85
DIST opam-full-2.1.2.tar.gz 9442446 BLAKE2B fe5447fe8f9bcedb30bf455e93b54a37e950e2944f6f501545bdccf6d989de2da90106938efb6a12c1b9454ecefed5be9906d65a15a4d0244302ad7ccff170db SHA512 fe12aaa27168435a978c472926d40697af0a7619a529c4bfacd0b71469dfcd534f43164bc74f60f740a735d38a869ae5e87e2414119f4f3fc1826315e8a075cd
DIST opam-full-2.1.3.tar.gz 9618995 BLAKE2B 6f33e70c2e59be87b643840128b46441828d3d83888f5d321ac23d33b2fbc4d3163cb4303ac82a7f863abcc9300227bbc48bca3b8db5d6fbcebf0e6cf8869a5d SHA512 fe3a3c86335830944683a39a34a9eb385037476853ab3e2a82b8571a9e2021830cccf25cbd5bb891d239f6a47584c1b1d91aa445e6e2a814847346c5cc526ff1
+DIST opam-full-2.1.5.tar.gz 10801367 BLAKE2B 5e6b1140e279931dfb61f68d0c4888cb14d05ff610e2b151115efe6b6420d74e7079894b6f4360f377b155008530ba4ace9708bc9d1e1d8c13950c0a5be4de11 SHA512 e4e33fcee0a9f922f8b43c6b095554a946559a2c50341326d21cca0f24fc7105c0de01db204b408240b12b267c9929435e2c511adf140618c91873f10444ae90
diff --git a/dev-ml/opam-installer/opam-installer-2.1.5.ebuild b/dev-ml/opam-installer/opam-installer-2.1.5.ebuild
new file mode 100644
index 000000000000..58de5666dc7c
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+inherit dune
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/_build/install/default/bin/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # sandbox not working
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3:=
+ dev-ml/cmdliner:=
+ ~dev-ml/opam-format-${PV}:=
+ >=dev-ml/dose3-6:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ dune-compile ${PN}
+}