summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-26 14:05:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-26 14:19:18 +0200
commit8a5b1b9ed2407fe4d46255ca0e8ef1775de25635 (patch)
treeb82f7fd7244477209e44b337d2c8f5ccb36183a9
parentdev-python/cypari2: new package, add 2.1.4 (diff)
downloadgentoo-8a5b1b9ed2407fe4d46255ca0e8ef1775de25635.tar.gz
gentoo-8a5b1b9ed2407fe4d46255ca0e8ef1775de25635.tar.bz2
gentoo-8a5b1b9ed2407fe4d46255ca0e8ef1775de25635.zip
dev-python/asttokens: Bump to 2.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/asttokens/Manifest1
-rw-r--r--dev-python/asttokens/asttokens-2.4.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/asttokens/Manifest b/dev-python/asttokens/Manifest
index 0b9bcb77fc28..44affc696802 100644
--- a/dev-python/asttokens/Manifest
+++ b/dev-python/asttokens/Manifest
@@ -1 +1,2 @@
DIST asttokens-2.4.0.gh.tar.gz 56965 BLAKE2B 60adc46bd30f5c2fee368362f655bb6a83d2394f2c0badfc191f91335decd523a2f1523927b4ce3cdbe1a557cfb335635c68c20acbb33384cf9c3a816bbb6743 SHA512 183321c6eef3493e49289834425d4ec59dec5fdc496d27e4d89ab5ca2a830306367e0464dba25856da612e018f8d6cefedf7c2349488884031f02a91acc73cd4
+DIST asttokens-2.4.1.gh.tar.gz 57358 BLAKE2B dff2bdbbb62ed0c99f620284e4ad4abe418c315356caee26988ed7722a9aec77be4fe79b877e350cf632e076cd7c421f6ec824e7ffdda1d6684b03fffb15e7b2 SHA512 62263e50e14953e98236cdcbd75121ff5f6a3dc949170412a97f17af9b2572415373971d2286c4821b03249404b5a4c53ef5c7f1ec37aa9e2bf4a743d16de1da
diff --git a/dev-python/asttokens/asttokens-2.4.1.ebuild b/dev-python/asttokens/asttokens-2.4.1.ebuild
new file mode 100644
index 000000000000..e02fe9c103c0
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/
+"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}