summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-16 07:15:12 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-16 07:15:12 +0200
commit876db2ea51ea71f7931dc432e430b1a59be77d4d (patch)
tree295ee6de99c65b370930457ac79ba2b3734fc868
parentdev-python/pyghmi: Bump to 1.5.70 (diff)
downloadgentoo-876db2ea51ea71f7931dc432e430b1a59be77d4d.tar.gz
gentoo-876db2ea51ea71f7931dc432e430b1a59be77d4d.tar.bz2
gentoo-876db2ea51ea71f7931dc432e430b1a59be77d4d.zip
dev-python/django-crispy-forms: Bump to 2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-crispy-forms/Manifest1
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-2.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
index d64678e65d22..7728848da81c 100644
--- a/dev-python/django-crispy-forms/Manifest
+++ b/dev-python/django-crispy-forms/Manifest
@@ -1 +1,2 @@
DIST django-crispy-forms-2.1.gh.tar.gz 274397 BLAKE2B 3f38830f370efde04494add3ddd2ce7f4a04b032b9aad770ba30885ed2b3a14cff3c748fa299041c9c1d7007b30eb55c96a46fe496c0432b187ae72879d4240e SHA512 703f353adc272905b4d5ebe21ea54e3016a3889703bf406dfdf92638dac2e6f536cf1bc16022be6a442f7dfa962ff17746edea591cf80c2be9440d9bb50a9dcc
+DIST django-crispy-forms-2.2.gh.tar.gz 274957 BLAKE2B bb80affa2050c1eee3bb706ab5fc48555676cf118b78ff4d28031c1df9c0e8adba9f1638cbea7f87c4edd2d655fb1a00de30b64e073b1f0f9b35a6103d9b9c08 SHA512 a379fbd1b9916aa3123a4c1af5c9da4916573c57b2e575cb189fe8cba23718490c9130ff55e7ae80dbb3d9476d449daf1f8c9f8caec80f394601af6246615f24
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-2.2.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-2.2.ebuild
new file mode 100644
index 000000000000..4a3efaf138b0
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="DRY Django forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/django-crispy-forms/
+ https://pypi.org/project/django-crispy-forms/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/django-crispy-forms/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap3[${PYTHON_USEDEP}]
+ dev-python/crispy-bootstrap4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest