summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 11:07:43 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:02:23 +0100
commit83333f963437598e0450795ff032a74a77a9603e (patch)
tree6f0bec838adf0d464e7825b1abffd6507f5b6d1a
parentdev-haskell/githash: add package (diff)
downloadgentoo-83333f963437598e0450795ff032a74a77a9603e.tar.gz
gentoo-83333f963437598e0450795ff032a74a77a9603e.tar.bz2
gentoo-83333f963437598e0450795ff032a74a77a9603e.zip
dev-haskell/hackage-security: bump up to 0.5.3.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/hackage-security/Manifest1
-rw-r--r--dev-haskell/hackage-security/files/hackage-security-0.5.3.0-ghc-8.8.patch12
-rw-r--r--dev-haskell/hackage-security/hackage-security-0.5.3.0-r3.ebuild68
-rw-r--r--dev-haskell/hackage-security/metadata.xml1
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-haskell/hackage-security/Manifest b/dev-haskell/hackage-security/Manifest
index 5b0310e15d5b..20ef9ff45791 100644
--- a/dev-haskell/hackage-security/Manifest
+++ b/dev-haskell/hackage-security/Manifest
@@ -1 +1,2 @@
DIST hackage-security-0.5.2.2.tar.gz 83131 BLAKE2B 4ce0ff3d4ee2647ac5311996756ce43aa91ee7989ef6a46ea94679890900811c770e5ce91acc0e39fe0e42767cdd6d21bb11bee7d385c9e3a30c642b9471f423 SHA512 5adab3c46d7aada8668128ad8c9389ca65489eec776f8571b8ee5834d74b961f19b558cb6642cbb1891ee381b2d4f2019dddf29bad13607fe23bef49a3d6f535
+DIST hackage-security-0.5.3.0.tar.gz 87119 BLAKE2B 6e69b13d3ee16fbc6488e1e9d926ba07d975555e9ad80c404ccfec60ff549e7eb2d40302ace8ac5f03ed5532c031f236f8a09edc8a3f8c7d4c2bb48743f88aa1 SHA512 57af812fb3911aed6ebdbc5de733e86a2bdc7845a07246c69346c59f654e7c4ae5bf20ad753cfe71dc1d7f47ce66a37fba49b178e8e6ff74002fc8ffb72d920d
diff --git a/dev-haskell/hackage-security/files/hackage-security-0.5.3.0-ghc-8.8.patch b/dev-haskell/hackage-security/files/hackage-security-0.5.3.0-ghc-8.8.patch
new file mode 100644
index 000000000000..7c30961a4b4d
--- /dev/null
+++ b/dev-haskell/hackage-security/files/hackage-security-0.5.3.0-ghc-8.8.patch
@@ -0,0 +1,12 @@
+diff -ru hackage-security-0.5.3.0.orig/src/Hackage/Security/TUF/FileMap.hs hackage-security-0.5.3.0/src/Hackage/Security/TUF/FileMap.hs
+--- hackage-security-0.5.3.0.orig/src/Hackage/Security/TUF/FileMap.hs 2018-03-25 19:39:07.000000000 -0400
++++ hackage-security-0.5.3.0/src/Hackage/Security/TUF/FileMap.hs 2019-03-16 08:29:08.347456951 -0400
+@@ -78,7 +78,7 @@
+ lookupM :: Monad m => FileMap -> TargetPath -> m FileInfo
+ lookupM m fp =
+ case lookup fp m of
+- Nothing -> fail $ "No entry for " ++ pretty fp ++ " in filemap"
++ Nothing -> error $ "No entry for " ++ pretty fp ++ " in filemap"
+ Just nfo -> return nfo
+
+ {-------------------------------------------------------------------------------
diff --git a/dev-haskell/hackage-security/hackage-security-0.5.3.0-r3.ebuild b/dev-haskell/hackage-security/hackage-security-0.5.3.0-r3.ebuild
new file mode 100644
index 000000000000..2c6a4be4ebc2
--- /dev/null
+++ b/dev-haskell/hackage-security/hackage-security-0.5.3.0-r3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage security library"
+HOMEPAGE="https://github.com/haskell/hackage-security"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RESTRICT=test # QC-2.10 finds counterexamples
+
+RDEPEND=">=dev-haskell/base16-bytestring-0.1.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/cabal-1.14:=[profile?]
+ >=dev-haskell/cryptohash-sha256-0.11:=[profile?] <dev-haskell/cryptohash-sha256-0.12:=[profile?]
+ >=dev-haskell/ed25519-0.0:=[profile?] <dev-haskell/ed25519-0.1:=[profile?]
+ >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/tar-0.5:=[profile?] <dev-haskell/tar-0.6:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+ >=dev-haskell/old-locale-1.0:=[profile?]
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.5:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( >=dev-haskell/quickcheck-2.9
+ >=dev-haskell/tasty-1.0
+ >=dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.10
+ >=dev-haskell/temporary-1.2
+ !network-uri? ( dev-haskell/network-uri ) )
+"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-8.8.patch)
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.12' 'base >= 4.5' \
+ 'tasty == 1.0.*' 'tasty >= 1.0' \
+ 'tasty-hunit == 0.10.*' 'tasty-hunit >= 0.10' \
+ 'tasty-quickcheck == 0.10.*' 'tasty-quickcheck >= 0.10' \
+ 'QuickCheck == 2.9.*' 'QuickCheck >= 2.9' \
+ 'temporary == 1.2.*' 'temporary >= 1.2' \
+ 'network >= 2.6 && < 2.7' 'network >= 2.6' \
+ 'Cabal >= 1.14 && < 2.4' 'Cabal >= 1.14' \
+ 'containers >= 0.4 && < 0.6' 'containers >= 0.4' \
+ 'time >= 1.2 && < 1.9' 'time >= 1.2'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri use-network-uri)
+}
diff --git a/dev-haskell/hackage-security/metadata.xml b/dev-haskell/hackage-security/metadata.xml
index a3594f6cd4ae..4a4ad2a438d2 100644
--- a/dev-haskell/hackage-security/metadata.xml
+++ b/dev-haskell/hackage-security/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="use-network-uri">Get Network.URI from the network-uri package.</flag>
+ <flag name="network-uri">Get Network.URI from the network-uri package.</flag>
</use>
<longdescription>
The hackage security library provides both server and