summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-13 16:13:05 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-13 17:40:16 +0100
commit80b89ddd26b549caf9b93796d1677a22eb7a3004 (patch)
treeead1846ee5b21ae81f8298d3dbeae5d4fc7d0dce
parentapp-emacs/jinx: drop old 1.1 (diff)
downloadgentoo-80b89ddd26b549caf9b93796d1677a22eb7a3004.tar.gz
gentoo-80b89ddd26b549caf9b93796d1677a22eb7a3004.tar.bz2
gentoo-80b89ddd26b549caf9b93796d1677a22eb7a3004.zip
app-emacs/jinx: bump to 1.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/jinx/Manifest1
-rw-r--r--app-emacs/jinx/jinx-1.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/jinx/Manifest b/app-emacs/jinx/Manifest
index 0e203430342b..af6dd628950f 100644
--- a/app-emacs/jinx/Manifest
+++ b/app-emacs/jinx/Manifest
@@ -1,2 +1,3 @@
DIST jinx-1.2.tar.gz 33991 BLAKE2B 37661f5d02bb3f1a1813bd5d4e78b6c6c115ef40fa1f346685956a02486870fbccb570490e05029550e281e0be02bde12f6cdd5b3bf6dc67041cab294759585d SHA512 bc5caa73a348c3a5aae6322290823c60f48127b915e173ae08385ee979e94d4d05c733ad0003c5ac4702828de5dffd2dfb88c7da720bafa4a85665657579e0d0
DIST jinx-1.3.tar.gz 34055 BLAKE2B c91652d0791ace223013f0ac42d3b917d3fff6cd5920d27bcf48f65ead3a7d29bc7090af107619ceedc243f34c7984a2dadb8fa667d6a825c8a21107de5f186a SHA512 14f03352e16cbcdbfa4c0fe9c00a2a496d7086a0a7dee9c82c5673069e98b0d9b472722a8e90f03815770bf8f054349833e3e7d035deb53a4fa9d05fa54899da
+DIST jinx-1.4.tar.gz 34299 BLAKE2B c28a1535826a1b3a4541cae33ec5ac7badc4fec0188d5b269b0dfbb7fb8a12bf642ea9efb9f1b7289de0bbce5f60cc756ede878a36e1b2b3ec2a8ee26a2fb892 SHA512 fcf08e25d3429ae801006050b56cbc16b65eaa26694b0b20a3c475de716c1c7d4271838b4d553caae257cd82215dd8154c6feb277fb5a16e05c1d098567605a0
diff --git a/app-emacs/jinx/jinx-1.4.ebuild b/app-emacs/jinx/jinx-1.4.ebuild
new file mode 100644
index 000000000000..fd1936d0c50c
--- /dev/null
+++ b/app-emacs/jinx/jinx-1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit edo elisp toolchain-funcs
+
+DESCRIPTION="Enchanted Spell Checker for GNU Emacs"
+HOMEPAGE="https://github.com/minad/jinx"
+
+SRC_URI="
+ https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/enchant:2
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="50${PN}-gentoo.el"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ edo $(tc-getCC) -fPIC -Wall -Wextra -shared \
+ $($(tc-getPKG_CONFIG) --cflags --libs enchant-2) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o jinx-mod.so jinx-mod.c
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ elisp-modules-install "${PN}" jinx-mod.so
+ doinfo jinx.info
+}