summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-07 11:52:43 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-07 12:35:55 +0100
commit755182177c537b8e5d7c459d51e651d1246b6f0b (patch)
tree866bf2c001c524c81c324bbe7f4d8afc06c251d6
parentdev-python/pytest-rerunfailures: Remove old (diff)
downloadgentoo-755182177c537b8e5d7c459d51e651d1246b6f0b.tar.gz
gentoo-755182177c537b8e5d7c459d51e651d1246b6f0b.tar.bz2
gentoo-755182177c537b8e5d7c459d51e651d1246b6f0b.zip
dev-python/wheel: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wheel/Manifest2
-rw-r--r--dev-python/wheel/files/wheel-0.44.0-ft.patch38
-rw-r--r--dev-python/wheel/wheel-0.44.0.ebuild55
-rw-r--r--dev-python/wheel/wheel-0.45.0.ebuild51
4 files changed, 0 insertions, 146 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index a19527d88ab4..c6f56f57d7b6 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1,3 +1 @@
-DIST wheel-0.44.0.tar.gz 100733 BLAKE2B 6beefa0875be52fb2dff2921cb87063bcafdf2e31c43963676fbae8aef4e68ea21675aa715f94052edc9f5e8dbbd5e2afe3abc17f521eb36b24fa628b0522bbe SHA512 f0a1efbf70e8a2eebdf7564932bdfa3892940a3fbfc00f256f61be03a51ff9cc5a55570d1d3f5878670be84ab233483453ce754ea46c508574fcf4ec61d480c8
-DIST wheel-0.45.0.tar.gz 107426 BLAKE2B 57cfbe247bbc2f0598a3ee18a1ab4b309e6ec6eb89486391bc7b5baa148736829b2620d05f1c6f75b0743ee1065ccbdc66ce690ee7efcf5f2b58519eb4cc8b25 SHA512 dca95cadde7c551baebde50f66ca79d4205d0a896da34b7f4f103c62fb72f78c0b9e71933564b951ab3878e6bc47d1961a73545bc0ead45e618de33b6b7cb16a
DIST wheel-0.45.1.tar.gz 107545 BLAKE2B 13c8d60a2e39ded3d911c9e03915b01bda201f7e8cd6de456484ce6eeb2a990861a01f26e5d9f2ac4ca0ab2b6d0fea9db437d6f82cb39db9b1059c3c53202ec0 SHA512 df45f00e9eaeae2f27f813f31591590c961da2f6bff15bba6fb2a14d529c221f39b29894b8da408fe49cd4b760840a0e05c4baef377ccfacd9983c0bba83d6d8
diff --git a/dev-python/wheel/files/wheel-0.44.0-ft.patch b/dev-python/wheel/files/wheel-0.44.0-ft.patch
deleted file mode 100644
index 600318dc275e..000000000000
--- a/dev-python/wheel/files/wheel-0.44.0-ft.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From d30f834fcec7ecdbb74e263789db2fbe9ff37e99 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Fri, 11 Oct 2024 16:12:50 +0200
-Subject: [PATCH] Skip abi3 tests when freethreading Python build is used
-
-Skip the tests using abi3 extension when the freethreading build is
-used, as Python 3.13 freethreading does not support the limited API
-and its use results in a build error.
-
-Fixes #636
----
- tests/conftest.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/tests/conftest.py b/tests/conftest.py
-index 5ee84da..d5bd356 100644
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -7,6 +7,7 @@ from __future__ import annotations
- import os.path
- import subprocess
- import sys
-+import sysconfig
-
- import pytest
-
-@@ -22,7 +23,7 @@ def wheels_and_eggs(tmp_path_factory):
- "unicode.dist",
- )
-
-- if sys.platform != "win32":
-+ if sys.platform != "win32" and sysconfig.get_config_var("Py_GIL_DISABLED") != 1:
- # ABI3 extensions don't really work on Windows
- test_distributions += ("abi3extension.dist",)
-
---
-2.47.0
-
diff --git a/dev-python/wheel/wheel-0.44.0.ebuild b/dev-python/wheel/wheel-0.44.0.ebuild
deleted file mode 100644
index aa0df30e0b2c..000000000000
--- a/dev-python/wheel/wheel-0.44.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..13} python3_13t pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="
- https://github.com/pypa/wheel/
- https://pypi.org/project/wheel/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos ~x64-solaris"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_DESELECT=(
- # fails if any setuptools plugin imported the module first
- tests/test_bdist_wheel.py::test_deprecated_import
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # https://github.com/pypa/wheel/pull/637
- "${FILESDIR}/${P}-ft.patch"
- )
-
- distutils-r1_src_prepare
-
- # unbundle packaging
- rm -r src/wheel/vendored || die
- sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
- sed -i -e 's:wheel\.vendored\.::' tests/*.py || die
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/wheel/wheel-0.45.0.ebuild b/dev-python/wheel/wheel-0.45.0.ebuild
deleted file mode 100644
index 95f482c44938..000000000000
--- a/dev-python/wheel/wheel-0.45.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..13} python3_13t pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="
- https://github.com/pypa/wheel/
- https://pypi.org/project/wheel/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_DESELECT=(
- # fails if any setuptools plugin imported the module first
- tests/test_bdist_wheel.py::test_deprecated_import
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # unbundle packaging
- rm -r src/wheel/vendored || die
- find -name '*.py' -exec sed -i \
- -e 's:wheel\.vendored\.::' \
- -e 's:\.\+vendored\.::' {} + || die
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}