summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-26 22:05:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-26 22:39:41 +0200
commit62b85c3ddad4340508a9cad24a2476f3f2d107f6 (patch)
tree0ffd9ceef11910117d215a5034d6b1dd0e53d805
parentdev-python/hypothesis: Bump to 6.13.6 (diff)
downloadgentoo-62b85c3ddad4340508a9cad24a2476f3f2d107f6.tar.gz
gentoo-62b85c3ddad4340508a9cad24a2476f3f2d107f6.tar.bz2
gentoo-62b85c3ddad4340508a9cad24a2476f3f2d107f6.zip
dev-python/pytest-rerunfailures: Bump to 10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-rerunfailures/Manifest1
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index 4c5c2ed604cc..c80efdcc2a6e 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1 +1,2 @@
+DIST pytest-rerunfailures-10.0.tar.gz 12706 BLAKE2B fb445acd6324a377258ebcd32255bd725dc78f2209990e5807a0553da259ffc101969b7572799efa5041ae68bcc264ab80581cf9d9943ab81d9b158a15dd71d5 SHA512 83270e18cc3f825c0e0184950a149899b99a2b46cfaa6ca1c82b7cf388144265831fc2b8b82ccebb5df57463219cb7e0b41f5beb049feedcba90ae6d48d1e05f
DIST pytest-rerunfailures-9.1.1.tar.gz 12435 BLAKE2B b2118fe9460ebb750c72b05762d70cf53703e4c9982c6343ef02ebcec6630598ac98998ff994268b9108bd6850e71fd5b9cde1d0abb727d33fad238e9b26fa61 SHA512 875591306ab010494ccbb865ea6445ab37422fce9105260d9495215af44057210564aca4fed3b4765b5a30c1cbef120de716d15d10a6db91dcb7d9f5b4f3b102
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.0.ebuild
new file mode 100644
index 000000000000..ab9103a1e97b
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="https://pypi.org/project/pytest-rerunfailures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+BDEPEND="
+ >=dev-python/pytest-5.0[${PYTHON_USEDEP}]
+ test? ( !!dev-python/flaky )
+"
+
+distutils_enable_tests pytest