summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-15 06:59:30 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-15 06:59:30 +0100
commit60e0330bf23380de11a210ceef777c740eed31a8 (patch)
treef792d169c9735b6b102b529708799f2d79b339d9
parentmedia-libs/openal: cleanup old (diff)
downloadgentoo-60e0330bf23380de11a210ceef777c740eed31a8.tar.gz
gentoo-60e0330bf23380de11a210ceef777c740eed31a8.tar.bz2
gentoo-60e0330bf23380de11a210ceef777c740eed31a8.zip
dev-ruby/tty-command: add 0.10.1
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/tty-command/Manifest1
-rw-r--r--dev-ruby/tty-command/tty-command-0.10.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/tty-command/Manifest b/dev-ruby/tty-command/Manifest
index 2549bd1792fb..f8235df7adfb 100644
--- a/dev-ruby/tty-command/Manifest
+++ b/dev-ruby/tty-command/Manifest
@@ -1,2 +1,3 @@
DIST tty-command-0.10.0.tar.gz 31592 BLAKE2B 34bb5a926ad32b236585a3e0d5bcfebc6a7d8b3ab3c63e60db30441f6f66b757260b35b40fe5e22ec96162253716d27111c0def59133e80c9dabbaf5f87f68da SHA512 5397f154603b1516be717ac35665623292d1454c18824cc688227f998c8d14e0744fc143e29dd93e737ae78f1800a1e5812ed6cbacb0df6ac4db28b2f096fcde
+DIST tty-command-0.10.1.tar.gz 32359 BLAKE2B 85dd115d113abda7464f1d6935a730c97c312bcd280c16bbff44f5da294ed9197df2615449656ce8d403b4118c6d363710eb32e49a2ebb3c75896f5feda85bce SHA512 aa707f3af6b72f20ea692469c7dc60bbf146bc59eaedf4a57408a463e7f96b48dc9ec60de31f2298e36b6d56320b238b4364ee0f90d1499784d001e963ea6fa1
DIST tty-command-0.9.0.tar.gz 30463 BLAKE2B fc0436a80b4b73040a89f085315f50e464efd91d6ee222f7b94eec5b94700089ae22963580febf8296377c859c67f1f21772ecd24d325af76308183df6070e2a SHA512 12c5c238ea34b7236b1c1b3115a7f490ae3986de686359ed390428f766aabdb35de7a1b29363b5be4e09e0fb6888b0c8a30eb466153f64b1d8a77620a657ffac
diff --git a/dev-ruby/tty-command/tty-command-0.10.1.ebuild b/dev-ruby/tty-command/tty-command-0.10.1.ebuild
new file mode 100644
index 000000000000..3b7a3370f289
--- /dev/null
+++ b/dev-ruby/tty-command/tty-command-0.10.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-command"
+SRC_URI="https://github.com/piotrmurach/tty-command/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pastel-0.8:0"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}