summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-06 08:37:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-06 11:45:26 +0100
commit54a1a189e9f6c1bb16428dcb6d358d97ac2043ad (patch)
tree0eb0a179c8e664bec47b3e20d8e5fdfcb7462a69
parentdev-util/pkgcheck: Bump to 0.9.2 (diff)
downloadgentoo-54a1a189e9f6c1bb16428dcb6d358d97ac2043ad.tar.gz
gentoo-54a1a189e9f6c1bb16428dcb6d358d97ac2043ad.tar.bz2
gentoo-54a1a189e9f6c1bb16428dcb6d358d97ac2043ad.zip
dev-python/dask: Bump to 2021.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2021.3.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 8c6e1f98e3d9..dd0646237c93 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,2 +1,3 @@
DIST dask-2021.1.1.tar.gz 3637063 BLAKE2B 6b2ec67f5551c4bba0fde8cecf02de6f24bbcd126a22c56c75e41a645a31f0fd7ba81aa8e5167f495122ca96e2113fa4893851eac382df1ccfaa8bf1be576ed3 SHA512 d1d093af6389b9e02e6040ef66159a4696c2dd91e12190cf9efc25ad5a0f790e3da9ada64a8a5e1cfceab7452957a503c6c303d3e2248e05ebac168a0f7c52f1
DIST dask-2021.2.0.tar.gz 3643277 BLAKE2B d34f706cefd068e42b32c84b05a46c24c98ba8391358140e2a7d2325d3a18cd855fbe9174ac8b8541e8274b83621fcb5c299d70fa5e2bcfe11214a2a32a82ce5 SHA512 da8baaa7cd211eb3ff123127aa9f599337c3af52f06e9a35331397ab580500dda7135addbfe27815a2b14957f7852d9c22a21b1d220af28c8561edaaabdf2e34
+DIST dask-2021.3.0.tar.gz 3672035 BLAKE2B 17b3e808603b8524e96273ad33b69689605707a1c187b32c8ed67f054e7f242525365956800017ad5685e0c306dcd21bcfb3dbb3f9920446f03553ceb0fdd9a8 SHA512 ba5b62dd51dad29a106a4fe38a5015f7e1d7ad11eaa21a524b7c8b7d916873b9e447d065c9009e8100662aa3b1f64718b164369f173fc84f5f085a1e369e091a
diff --git a/dev-python/dask/dask-2021.3.0.ebuild b/dev-python/dask/dask-2021.3.0.ebuild
new file mode 100644
index 000000000000..991bf4a4899c
--- /dev/null
+++ b/dev-python/dask/dask-2021.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv -p no:flaky -m "not network" ||
+ die "Tests failed with ${EPYTHON}"
+}