summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-09-16 16:03:29 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-09-16 16:56:05 +0200
commit50b2dbcd174a8bf3807485646ced794bb6b01756 (patch)
tree7f907600107293ee7cd666d78c20254b2194513f
parentdev-embedded/dc-tool-ip: Port to EAPI 7 (diff)
downloadgentoo-50b2dbcd174a8bf3807485646ced794bb6b01756.tar.gz
gentoo-50b2dbcd174a8bf3807485646ced794bb6b01756.tar.bz2
gentoo-50b2dbcd174a8bf3807485646ced794bb6b01756.zip
dev-python/glooey: new package
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17565 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
-rw-r--r--dev-python/glooey/Manifest1
-rw-r--r--dev-python/glooey/glooey-0.3.1.ebuild33
-rw-r--r--dev-python/glooey/metadata.xml20
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/glooey/Manifest b/dev-python/glooey/Manifest
new file mode 100644
index 000000000000..f4987002ca4d
--- /dev/null
+++ b/dev-python/glooey/Manifest
@@ -0,0 +1 @@
+DIST glooey-0.3.1.tar.gz 19110562 BLAKE2B 252621789def523e3f8535ff6d72d3b5e71664cc5a0b2b4440b64be8170c08f275709c1771d2ab154349da643a521dae352e711b7f0a705f0e6eaeb1bd842932 SHA512 c804125bc9ccd9f2b44cc5fcf5a0c7353402aa8587641fc75870bf0c2474c449936dd41ddc641050009f32dbaef4e05fecd4c60c477c0c89512a02028f957c65
diff --git a/dev-python/glooey/glooey-0.3.1.ebuild b/dev-python/glooey/glooey-0.3.1.ebuild
new file mode 100644
index 000000000000..f6ee41b5d1ce
--- /dev/null
+++ b/dev-python/glooey/glooey-0.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..9})
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="An object-oriented GUI library for pyglet"
+HOMEPAGE="https://glooey.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/autoprop[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/vecrec[${PYTHON_USEDEP}]
+"
+
+BDEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
diff --git a/dev-python/glooey/metadata.xml b/dev-python/glooey/metadata.xml
new file mode 100644
index 000000000000..28c0e77535aa
--- /dev/null
+++ b/dev-python/glooey/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Every game needs a user interface that matches its look and feel. The purpose of glooey is to help you make
+ such an interface. Towards this end, glooey provides 7 powerful placement widgets, a label widget, an image
+ widget, 3 different button widgets, a text entry widget, a variety of scroll boxes and bars, 4 different dialog
+ box widgets, and a variety of other miscellaneous widgets. The appearance of any widget can be trivially
+ customized, and glooey comes with built-in fantasy, puzzle, and 8-bit themes to prove it (and to help you hit
+ the ground running if your game fits one of those genres).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kxgames/glooey</remote-id>
+ <remote-id type="pypi">glooey</remote-id>
+ </upstream>
+</pkgmetadata>