summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-26 16:37:02 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-26 16:37:06 +0100
commit350edb552c5f777633fbfbf645dc32081cb2abb4 (patch)
tree83e9d45fbc010917dc6d6159e0ec174f0ffa03ca
parentmedia-gfx/gnofract4d: Stabilize 4.3_p20201029 x86, #772116 (diff)
downloadgentoo-350edb552c5f777633fbfbf645dc32081cb2abb4.tar.gz
gentoo-350edb552c5f777633fbfbf645dc32081cb2abb4.tar.bz2
gentoo-350edb552c5f777633fbfbf645dc32081cb2abb4.zip
net-libs/zeromq: fix automagic on dev-libs/libbsd
Link: https://github.com/zeromq/libzmq/commit/068385c951c0608edec6264d55ba9c4c923acccc Closes: https://bugs.gentoo.org/772965 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--net-libs/zeromq/metadata.xml4
-rw-r--r--net-libs/zeromq/zeromq-4.3.3-r1.ebuild (renamed from net-libs/zeromq/zeromq-4.3.3.ebuild)4
-rw-r--r--net-libs/zeromq/zeromq-4.3.4-r1.ebuild (renamed from net-libs/zeromq/zeromq-4.3.4.ebuild)4
3 files changed, 10 insertions, 2 deletions
diff --git a/net-libs/zeromq/metadata.xml b/net-libs/zeromq/metadata.xml
index 8d747a412580..e46f5a985b5c 100644
--- a/net-libs/zeromq/metadata.xml
+++ b/net-libs/zeromq/metadata.xml
@@ -32,6 +32,10 @@
Build draft API, which may change at any time without any notice, and
is therefore not recommended for normal use.
</flag>
+ <flag name="libbsd">
+ Use strlcpy() from <pkg>dev-libs/libbsd</pkg> instead of internal
+ implementation.
+ </flag>
<flag name="pgm">
Build PGM (Pragmatic General Multicast)extention, a protocol for reliable
multicast transport of data over IP networks.
diff --git a/net-libs/zeromq/zeromq-4.3.3.ebuild b/net-libs/zeromq/zeromq-4.3.3-r1.ebuild
index 54387064008c..aacebe8becf4 100644
--- a/net-libs/zeromq/zeromq-4.3.3.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.3-r1.ebuild
@@ -12,11 +12,12 @@ SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0/5"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc drafts pgm +sodium static-libs test unwind elibc_Darwin"
+IUSE="doc drafts +libbsd pgm +sodium static-libs test unwind elibc_Darwin"
RESTRICT="!test? ( test )"
RDEPEND="
!elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
+ libbsd? ( dev-libs/libbsd:= )
sodium? ( dev-libs/libsodium:= )
pgm? ( ~net-libs/openpgm-5.2.122 )"
DEPEND="${RDEPEND}
@@ -39,6 +40,7 @@ src_configure() {
local myeconfargs=(
--enable-shared
$(use_enable drafts)
+ $(use_enable libbsd)
$(use_enable static-libs static)
$(use_enable unwind libunwind)
$(use_with sodium libsodium)
diff --git a/net-libs/zeromq/zeromq-4.3.4.ebuild b/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
index 21302e285a65..a17c74cf70e3 100644
--- a/net-libs/zeromq/zeromq-4.3.4.ebuild
+++ b/net-libs/zeromq/zeromq-4.3.4-r1.ebuild
@@ -12,11 +12,12 @@ SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0/5"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc drafts pgm +sodium static-libs test unwind elibc_Darwin"
+IUSE="doc drafts +libbsd pgm +sodium static-libs test unwind elibc_Darwin"
RESTRICT="!test? ( test )"
RDEPEND="
!elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
+ libbsd? ( dev-libs/libbsd:= )
sodium? ( dev-libs/libsodium:= )
pgm? ( ~net-libs/openpgm-5.2.122 )"
DEPEND="${RDEPEND}
@@ -39,6 +40,7 @@ src_configure() {
local myeconfargs=(
--enable-shared
$(use_enable drafts)
+ $(use_enable libbsd)
$(use_enable static-libs static)
$(use_enable unwind libunwind)
$(use_with sodium libsodium)