summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-04-22 18:56:24 -0400
committerSam James <sam@gentoo.org>2024-05-03 12:23:09 +0100
commit3431299ebe0ad8b9bfa4879b90971f58dc71ff30 (patch)
tree8a1cc2bea43144c97766ba7488480c3413b041c8
parentmedia-gfx/fontforge: forwardport py3.12 (diff)
downloadgentoo-3431299ebe0ad8b9bfa4879b90971f58dc71ff30.tar.gz
gentoo-3431299ebe0ad8b9bfa4879b90971f58dc71ff30.tar.bz2
gentoo-3431299ebe0ad8b9bfa4879b90971f58dc71ff30.zip
sci-libs/shapelib: add 1.6.0, security bump
- Bump subslot (now installs as libshp.so.4) - Tests pass - Bump to EAPI 8 - Convert SRC_URI to HTTPS - Convert econf args to array Bug: https://bugs.gentoo.org/877605 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/36367 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/shapelib/Manifest1
-rw-r--r--sci-libs/shapelib/shapelib-1.6.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/shapelib/Manifest b/sci-libs/shapelib/Manifest
index ff4f4c34ead8..f6d1ed67d993 100644
--- a/sci-libs/shapelib/Manifest
+++ b/sci-libs/shapelib/Manifest
@@ -1 +1,2 @@
DIST shapelib-1.5.0.tar.gz 547686 BLAKE2B 3f962ee701d8cfb86a56aa1c0b2156bc2288a2bc908bb1a8303e491812845241f5281b0b8650befcc53e9dfc408b652a56f5e2fdc5ac7c2ff6eb99170696e437 SHA512 6dbd5fc7929ca403e65017ef58211f351608d9ad08221bf68bde047ceecfd27013ce731f9ae4edcfd040bc3db7fe9054b5d96e46128d2968788bef19532b1721
+DIST shapelib-1.6.0.tar.gz 528882 BLAKE2B 02561b947ede10dcbb04ebe4d007b99ac2421ab56251a981e0bf4033b33bc5ae3a09a919c295a41797e7c295424d027a5f650848196f945918f7d6aeea177f89 SHA512 cc0b5841da5039c0467291994b9cd3aa99bebe70adf8db01719336a0eb2f0d7362395806f99228ba1f7ec68f0c5ecf9f7f5f1018093cf8dad9e06f0ae147c3fc
diff --git a/sci-libs/shapelib/shapelib-1.6.0.ebuild b/sci-libs/shapelib/shapelib-1.6.0.ebuild
new file mode 100644
index 000000000000..576d2163972f
--- /dev/null
+++ b/sci-libs/shapelib/shapelib-1.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library for manipulating ESRI Shapefiles"
+HOMEPAGE="http://shapelib.maptools.org/"
+SRC_URI="https://download.osgeo.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+src_prepare() {
+ default
+ rm -f m4/* || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --includedir="${EPREFIX}"/usr/include/libshp
+ --prefix="${EPREFIX}"/usr
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ use doc && HTML_DOCS=( web/. )
+ default
+
+ if ! use static-libs; then
+ find "${ED}" \( -name '*.la' -o -name '*.a' \) -delete || die
+ fi
+}